blob: e66bade7f0d44139c89b2e79f702199f3de5ac8e [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "biossums tool for building Plex86/Bochs LGPL VGABios"
2HOMEPAGE = "http://www.nongnu.org/vgabios/"
3LICENSE = "LGPLv2.1"
4SECTION = "firmware"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=dcf3c825659e82539645da41a7908589"
7
8SRC_URI = "http://savannah.gnu.org/download/vgabios/vgabios-${PV}.tgz"
9
10SRC_URI[md5sum] = "2c0fe5c0ca08082a9293e3a7b23dc900"
11SRC_URI[sha256sum] = "9d24c33d4bfb7831e2069cf3644936a53ef3de21d467872b54ce2ea30881b865"
12
13BBCLASSEXTEND = "native"
14
15FILES_${PN} = "${bindir}/biossums"
16
17S = "${WORKDIR}/vgabios-${PV}"
18
19do_configure() {
20 # Don't override the compiler or its flags:
21 sed 's,^CC,DISABLED_CC,' -i Makefile
22 sed 's,^CFLAGS,DISABLED_CFLAGS,' -i Makefile
23 sed 's,^LDFLAGS,DISABLED_LDFLAGS,' -i Makefile
24 # Supply the C flags to the compiler:
25 sed 's,-o biossums,$(CFLAGS) -o biossums,' -i Makefile
26}
27
28do_compile() {
29 # clean removes binaries distributed with source
30 oe_runmake clean
31 oe_runmake biossums
32}
33
34do_install() {
35 mkdir -p "${D}${bindir}"
36 install -m 0755 biossums "${D}${bindir}"
37}