blob: f1fc56449225878700fee43990396a0a8be284a3 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require u-boot-common_${PV}.inc
2
3SUMMARY = "U-Boot bootloader image creation tool"
4DEPENDS = "openssl"
5
6EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
7EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
8EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
9
10do_compile () {
11 oe_runmake sandbox_defconfig
12
13 # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
14 # generating it requires bin2header tool, which for target build
15 # is built with target tools and thus cannot be executed on host.
16 sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config
17
18 oe_runmake cross_tools NO_SDL=1
19}
20
21do_install () {
22 install -d ${D}${bindir}
23 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
24 ln -sf uboot-mkimage ${D}${bindir}/mkimage
25}
26
27BBCLASSEXTEND = "native nativesdk"