blob: d917c4d71311b4688784d9f5f25573822d2a01f2 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "userspace utilities for kernel nfs"
2DESCRIPTION = "The nfs-utils package provides a daemon for the kernel \
3NFS server and related tools."
4HOMEPAGE = "http://nfs.sourceforge.net/"
5SECTION = "console/network"
6
7LICENSE = "MIT & GPLv2+ & BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84"
9
10# util-linux for libblkid
11DEPENDS = "libcap libnfsidmap libevent util-linux sqlite3 libtirpc"
12RDEPENDS_${PN} = "${PN}-client bash"
13RRECOMMENDS_${PN} = "kernel-module-nfsd"
14
15inherit useradd
16
17USERADD_PACKAGES = "${PN}-client"
18USERADD_PARAM_${PN}-client = "--system --home-dir /var/lib/nfs \
19 --shell /bin/false --user-group rpcuser"
20
21SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.xz \
22 file://0001-configure-Allow-to-explicitly-disable-nfsidmap.patch \
23 file://nfs-utils-1.2.3-sm-notify-res_init.patch \
24 file://nfsserver \
25 file://nfscommon \
26 file://nfs-utils.conf \
27 file://nfs-server.service \
28 file://nfs-mountd.service \
29 file://nfs-statd.service \
30 file://proc-fs-nfsd.mount \
31 file://nfs-utils-Do-not-pass-CFLAGS-to-gcc-while-building.patch \
32 file://nfs-utils-debianize-start-statd.patch \
33 file://bugfix-adjust-statd-service-name.patch \
34 file://0001-include-stdint.h-for-UINT16_MAX-definition.patch \
35"
36
37SRC_URI[md5sum] = "59dfcb2e6254b129f901f40c86086b13"
38SRC_URI[sha256sum] = "0faeb54c70b84e6bd3b9b6901544b1f6add8d246f35c1683e402daf4e0c719ef"
39
40# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
41# pull in the remainder of the dependencies.
42
43INITSCRIPT_PACKAGES = "${PN} ${PN}-client"
44INITSCRIPT_NAME = "nfsserver"
45INITSCRIPT_PARAMS = "defaults"
46INITSCRIPT_NAME_${PN}-client = "nfscommon"
47INITSCRIPT_PARAMS_${PN}-client = "defaults 19 21"
48
49inherit autotools-brokensep update-rc.d systemd pkgconfig
50
51SYSTEMD_PACKAGES = "${PN} ${PN}-client"
52SYSTEMD_SERVICE_${PN} = "nfs-server.service nfs-mountd.service"
53SYSTEMD_SERVICE_${PN}-client = "nfs-statd.service"
54
55# --enable-uuid is need for cross-compiling
56EXTRA_OECONF = "--with-statduser=rpcuser \
57 --enable-mountconfig \
58 --enable-libmount-mount \
59 --disable-nfsv41 \
60 --enable-uuid \
61 --disable-gss \
62 --disable-nfsdcltrack \
63 --with-statdpath=/var/lib/nfs/statd \
64 "
65
66PACKAGECONFIG ??= "tcp-wrappers \
67 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
68"
69PACKAGECONFIG_remove_libc-musl = "tcp-wrappers"
70PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers,tcp-wrappers"
71PACKAGECONFIG[nfsidmap] = "--enable-nfsidmap,--disable-nfsidmap,keyutils"
72PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
73
74PACKAGES =+ "${PN}-client ${PN}-mount ${PN}-stats"
75
76CONFFILES_${PN}-client += "${localstatedir}/lib/nfs/etab \
77 ${localstatedir}/lib/nfs/rmtab \
78 ${localstatedir}/lib/nfs/xtab \
79 ${localstatedir}/lib/nfs/statd/state \
80 ${sysconfdir}/nfsmount.conf"
81
82FILES_${PN}-client = "${sbindir}/*statd \
83 ${sbindir}/rpc.idmapd ${sbindir}/sm-notify \
84 ${sbindir}/showmount ${sbindir}/nfsstat \
85 ${localstatedir}/lib/nfs \
86 ${sysconfdir}/nfs-utils.conf \
87 ${sysconfdir}/nfsmount.conf \
88 ${sysconfdir}/init.d/nfscommon \
89 ${systemd_unitdir}/system/nfs-statd.service"
90RDEPENDS_${PN}-client = "${PN}-mount rpcbind"
91
92FILES_${PN}-mount = "${base_sbindir}/*mount.nfs*"
93
94FILES_${PN}-stats = "${sbindir}/mountstats ${sbindir}/nfsiostat"
95RDEPENDS_${PN}-stats = "python3-core"
96
97FILES_${PN} += "${systemd_unitdir}"
98
99do_configure_prepend() {
100 sed -i -e 's,sbindir = /sbin,sbindir = ${base_sbindir},g' \
101 ${S}/utils/mount/Makefile.am
102
103 sed -i -e 's,sbindir = /sbin,sbindir = ${base_sbindir},g' \
104 ${S}/utils/osd_login/Makefile.am
105}
106
107# Make clean needed because the package comes with
108# precompiled 64-bit objects that break the build
109do_compile_prepend() {
110 make clean
111}
112
113do_install_append () {
114 install -d ${D}${sysconfdir}/init.d
115 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
116 install -m 0755 ${WORKDIR}/nfscommon ${D}${sysconfdir}/init.d/nfscommon
117
118 install -m 0755 ${WORKDIR}/nfs-utils.conf ${D}${sysconfdir}
119 install -m 0755 ${S}/utils/mount/nfsmount.conf ${D}${sysconfdir}
120
121 install -d ${D}${systemd_unitdir}/system
122 install -m 0644 ${WORKDIR}/nfs-server.service ${D}${systemd_unitdir}/system/
123 install -m 0644 ${WORKDIR}/nfs-mountd.service ${D}${systemd_unitdir}/system/
124 install -m 0644 ${WORKDIR}/nfs-statd.service ${D}${systemd_unitdir}/system/
125 sed -i -e 's,@SBINDIR@,${sbindir},g' \
126 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
127 ${D}${systemd_unitdir}/system/*.service
128 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
129 install -m 0644 ${WORKDIR}/proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/
130 install -d ${D}${systemd_unitdir}/system/sysinit.target.wants/
131 ln -sf ../proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/sysinit.target.wants/proc-fs-nfsd.mount
132 fi
133
134 # kernel code as of 3.8 hard-codes this path as a default
135 install -d ${D}/var/lib/nfs/v4recovery
136
137 # chown the directories and files
138 chown -R rpcuser:rpcuser ${D}${localstatedir}/lib/nfs/statd
139 chmod 0644 ${D}${localstatedir}/lib/nfs/statd/state
140
141 # the following are built by CC_FOR_BUILD
142 rm -f ${D}${sbindir}/rpcdebug
143 rm -f ${D}${sbindir}/rpcgen
144 rm -f ${D}${sbindir}/locktest
145
146 # Make python tools use python 3
147 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${sbindir}/mountstats ${D}${sbindir}/nfsiostat
148
149}