blob: 744085f4139e61a166f890114eede43a34da1adb [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Cross locale generation tool for glibc"
2HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
3SECTION = "libs"
4LICENSE = "LGPL-2.1"
5
6LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
9 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11# Tell autotools that we're working in the localedef directory
12#
13AUTOTOOLS_SCRIPT_PATH = "${S}/localedef"
14
15inherit native
16inherit autotools
17
18FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:"
19
20SRCBRANCH ?= "release/${PV}/master"
21GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git"
22UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.\d+(\.\d+)*)"
23
Brad Bishop00111322018-04-01 22:23:53 -040024SRCREV_glibc ?= "d300041c533a3d837c9f37a099bcc95466860e98"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050025SRCREV_localedef ?= "dfb4afe551c6c6e94f9cc85417bd1f582168c843"
26
27SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
28 git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef \
29 file://0015-timezone-re-written-tzselect-as-posix-sh.patch \
30 file://0016-Remove-bash-dependency-for-nscd-init-script.patch \
31 file://0017-eglibc-Cross-building-and-testing-instructions.patch \
32 file://0018-eglibc-Help-bootstrap-cross-toolchain.patch \
33 file://0019-eglibc-Clear-cache-lines-on-ppc8xx.patch \
34 file://0020-eglibc-Resolve-__fpscr_values-on-SH4.patch \
35 file://0021-eglibc-Install-PIC-archives.patch \
36 file://0022-eglibc-Forward-port-cross-locale-generation-support.patch \
37 file://0023-Define-DUMMY_LOCALE_T-if-not-defined.patch \
Brad Bishop00111322018-04-01 22:23:53 -040038 file://archive-path.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050039"
40# Makes for a rather long rev (22 characters), but...
41#
42SRCREV_FORMAT = "glibc_localedef"
43
44S = "${WORKDIR}/git"
45
46EXTRA_OECONF = "--with-glibc=${S}"
47CFLAGS += "-fgnu89-inline -std=gnu99 -DIS_IN\(x\)='0'"
48
49do_install() {
50 install -d ${D}${bindir}
51 install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
52}