blob: 9d1e636bbcb5f2449d333bfcce9e2a5e3670dc5e [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require glibc.inc
2
3LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
4 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
6 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
7
8DEPENDS += "gperf-native bison-native"
9
Brad Bishop00111322018-04-01 22:23:53 -040010SRCREV ?= "d300041c533a3d837c9f37a099bcc95466860e98"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050011
12SRCBRANCH ?= "release/${PV}/master"
13
14GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git"
15UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.\d+(\.\d+)*)"
16
17SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
18 file://etc/ld.so.conf \
19 file://generate-supported.mk \
20 \
21 ${NATIVESDKFIXES} \
22 file://0005-fsl-e500-e5500-e6500-603e-fsqrt-implementation.patch \
23 file://0006-readlib-Add-OECORE_KNOWN_INTERPRETER_NAMES-to-known-.patch \
24 file://0007-ppc-sqrt-Fix-undefined-reference-to-__sqrt_finite.patch \
25 file://0008-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
26 file://0009-Quote-from-bug-1443-which-explains-what-the-patch-do.patch \
27 file://0010-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
28 file://0011-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
29 file://0012-sysdeps-gnu-configure.ac-handle-correctly-libc_cv_ro.patch \
30 file://0013-Add-unused-attribute.patch \
31 file://0014-yes-within-the-path-sets-wrong-config-variables.patch \
32 file://0015-timezone-re-written-tzselect-as-posix-sh.patch \
33 file://0016-Remove-bash-dependency-for-nscd-init-script.patch \
34 file://0017-eglibc-Cross-building-and-testing-instructions.patch \
35 file://0018-eglibc-Help-bootstrap-cross-toolchain.patch \
36 file://0019-eglibc-Clear-cache-lines-on-ppc8xx.patch \
37 file://0020-eglibc-Resolve-__fpscr_values-on-SH4.patch \
38 file://0021-eglibc-Install-PIC-archives.patch \
39 file://0022-eglibc-Forward-port-cross-locale-generation-support.patch \
40 file://0023-Define-DUMMY_LOCALE_T-if-not-defined.patch \
41 file://0024-elf-dl-deps.c-Make-_dl_build_local_scope-breadth-fir.patch \
42 file://0025-locale-fix-hard-coded-reference-to-gcc-E.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050043 file://0027-glibc-reset-dl-load-write-lock-after-forking.patch \
44 file://0028-Bug-4578-add-ld.so-lock-while-fork.patch \
Brad Bishop00111322018-04-01 22:23:53 -040045 file://0029-bits-siginfo-consts.h-enum-definition-for-TRAP_HWBKP.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050046"
47
48NATIVESDKFIXES ?= ""
49NATIVESDKFIXES_class-nativesdk = "\
50 file://0001-nativesdk-glibc-Look-for-host-system-ld.so.cache-as-.patch \
51 file://0002-nativesdk-glibc-Fix-buffer-overrun-with-a-relocated-.patch \
52 file://0003-nativesdk-glibc-Raise-the-size-of-arrays-containing-.patch \
53 file://0004-nativesdk-glibc-Allow-64-bit-atomics-for-x86.patch \
Brad Bishop00111322018-04-01 22:23:53 -040054 file://relocate-locales.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050055"
56
57S = "${WORKDIR}/git"
58B = "${WORKDIR}/build-${TARGET_SYS}"
59
60PACKAGES_DYNAMIC = ""
61
62# the -isystem in bitbake.conf screws up glibc do_stage
63BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
64TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
65
66GLIBC_BROKEN_LOCALES = ""
67#
68# We will skip parsing glibc when target system C library selection is not glibc
69# this helps in easing out parsing for non-glibc system libraries
70#
71COMPATIBLE_HOST_libc-musl_class-target = "null"
72
73EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
74 --without-cvs --disable-profile \
75 --disable-debug --without-gd \
76 --enable-clocale=gnu \
77 --enable-add-ons=libidn \
78 --with-headers=${STAGING_INCDIR} \
79 --without-selinux \
80 --enable-obsolete-rpc \
81 --enable-obsolete-nsl \
82 --enable-tunables \
83 --enable-bind-now \
84 --enable-stack-protector=strong \
85 --enable-stackguard-randomization \
86 ${GLIBC_EXTRA_OECONF}"
87
88EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
89EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'libc-inet-anl', '--enable-nscd', '--disable-nscd', d)}"
90
91
92do_patch_append() {
93 bb.build.exec_func('do_fix_readlib_c', d)
94}
95
96do_fix_readlib_c () {
97 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
98}
99
100do_configure () {
101# override this function to avoid the autoconf/automake/aclocal/autoheader
102# calls for now
103# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
104# version check and doesn't really help with anything
105 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
106 find ${S} -name "configure" | xargs touch
107 # "plural.c" may or may not get regenerated from "plural.y" so we
108 # touch "plural.y" to make sure it does. (This should not be needed
109 # for glibc version 2.26+)
110 find ${S}/intl -name "plural.y" | xargs touch
111 CPPFLAGS="" oe_runconf
112}
113
114rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
115 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
116 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
117
118do_compile () {
119 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
120 unset LDFLAGS
121 base_do_compile
122 (
123 cd ${S}/sunrpc/rpcsvc
124 for r in ${rpcsvc}; do
125 h=`echo $r|sed -e's,\.x$,.h,'`
126 rm -f $h
127 ${B}/sunrpc/cross-rpcgen -h $r -o $h || bbwarn "${PN}: unable to generate header for $r"
128 done
129 )
130 echo "Adjust ldd script"
131 if [ -n "${RTLDLIST}" ]
132 then
133 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
134 if [ "${prevrtld}" != "${RTLDLIST}" ]
135 then
136 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#"
137 fi
138 fi
139
140}
141
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500142require glibc-package.inc
143
144BBCLASSEXTEND = "nativesdk"