blob: 02b69f37a4d474a4a68b3ec5596a3330ba570f7f [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "initramfs-framework module for installation option"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4RDEPENDS_${PN} = "initramfs-framework-base grub parted e2fsprogs-mke2fs util-linux-blkid"
5
6# The same restriction as grub
7COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*)-(linux.*|freebsd.*)'
8COMPATIBLE_HOST_armv7a = 'null'
9COMPATIBLE_HOST_armv7ve = 'null'
10
11PR = "r1"
12
13SRC_URI = "file://init-install.sh"
14
15S = "${WORKDIR}"
16
17do_install() {
18 install -d ${D}/init.d
19 install -m 0755 ${WORKDIR}/init-install.sh ${D}/init.d/install.sh
20}
21
22FILES_${PN} = "/init.d/install.sh"