blob: 423b47a076acac5b5480d5f677999b617beca03a [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Keytable files and keyboard utilities"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "http://www.kbd-project.org/"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05003# everything minus console-fonts is GPLv2+
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a5fcc36121d93e1f69d96a313078c8b5"
6DEPENDS = "libcheck"
7
8inherit autotools gettext ptest pkgconfig
9
10RREPLACES_${PN} = "console-tools"
11RPROVIDES_${PN} = "console-tools"
12RCONFLICTS_${PN} = "console-tools"
13
14SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/${BP}.tar.xz \
15 file://run-ptest \
16 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'file://set-proper-path-of-resources.patch', '', d)} \
17 "
18
19SRC_URI[md5sum] = "c1635a5a83b63aca7f97a3eab39ebaa6"
20SRC_URI[sha256sum] = "5fd90af6beb225a9bb9b9fb414c090fba53c9a55793e172f508cd43652e59a88"
21
22PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}"
23PACKAGECONFIG[pam] = "--enable-vlock, --disable-vlock, libpam,"
24
25do_compile_ptest() {
26 oe_runmake -C ${B}/tests dumpkeys-fulltable alt-is-meta
27}
28
29do_install_ptest() {
30 install -D ${B}/tests/Makefile ${D}${PTEST_PATH}/tests/Makefile
31 sed -i -e '/Makefile:/,/^$/d' -e '/%: %.in/,/^$/d' \
32 -e '/libkeymap_.*_SOURCES =/d' -e '/$(EXEEXT):/,/^$/d' ${D}${PTEST_PATH}/tests/Makefile
33
34 find ${B}/tests -executable -exec install {} ${D}${PTEST_PATH}/tests \;
35 find ${S}/tests \( -name \*.map -o -name \*.bin -o -name \*.output \) -exec install {} ${D}${PTEST_PATH}/tests \;
36
37 install -D -m 755 ${S}/config/test-driver ${D}${PTEST_PATH}/config/test-driver
38}
39
40PACKAGES += "${PN}-consolefonts ${PN}-keymaps ${PN}-unimaps ${PN}-consoletrans"
41
42FILES_${PN}-consolefonts = "${datadir}/consolefonts"
43FILES_${PN}-consoletrans = "${datadir}/consoletrans"
44FILES_${PN}-keymaps = "${datadir}/keymaps"
45FILES_${PN}-unimaps = "${datadir}/unimaps"
46
47RDEPENDS_${PN}-ptest = "make"
48
49inherit update-alternatives
50
51ALTERNATIVE_${PN} = "chvt deallocvt fgconsole openvt"
52ALTERNATIVE_PRIORITY = "100"
53
54BBCLASSEXTEND = "native"