blob: c3cc89c2b0fa71bd0d41b372c00529d0b8310174 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl"
14DEPENDS_append_class-target = " udev"
15RDEPENDS_${PN} = "libgcc"
16
17SRCREV = "0607132c3200bcead1426e6dc685432008de95de"
18SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
19 file://0001-Makefile-build-mktables-using-native-gcc.patch \
20 "
21
22inherit autotools-brokensep pkgconfig manpages
23
24PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
25EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
26
27do_configure_prepend() {
28 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
29 mkdir -p ${S}/config
30 cp -f $(automake --print-libdir)/install-sh ${S}/config/
31}
32
33S = "${WORKDIR}/git"
34
35BBCLASSEXTEND = "native"