blob: 84d04cfa0d33c6e7e685c9ba9d3d253a3a6f864b [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Build Result Compare Script"
2DESCRIPTION = "This package contains scripts to find out if the build result\
3differs to a former build."
4HOMEPAGE = "https://github.com/openSUSE/build-compare"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7
8SRC_URI = "git://github.com/openSUSE/build-compare.git \
9 file://Rename-rpm-check.sh-to-pkg-diff.sh.patch;striplevel=1 \
10 file://Ignore-DWARF-sections.patch;striplevel=1 \
11 file://0001-Add-support-for-deb-and-ipk-packaging.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060012 file://functions.sh-remove-space-at-head.patch \
13 file://functions.sh-run-rpm-once-to-make-it-faster.patch \
14 file://pkg-diff.sh-check-for-fifo-named-pipe.patch \
15 file://pkg-diff.sh-check_single_file-return-at-once-when-sa.patch \
16 file://pkg-diff.sh-remove-space-in-the-end-for-ftype.patch \
17 file://functions.sh-improve-deb-and-ipk-checking.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018 "
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020# Date matches entry in build-compare.changes and date of SRCREV.
21#
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022SRCREV = "c5352c054c6ef15735da31b76d6d88620f4aff0a"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023PE = "1"
24PV = "2015.02.10+git${SRCPV}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050025UPSTREAM_VERSION_UNKNOWN = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026
27S = "${WORKDIR}/git"
28
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029BBCLASSEXTEND = "native nativesdk"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030
31do_install() {
32 install -d ${D}/${bindir}
33 install -m 755 functions.sh ${D}/${bindir}
34 install -m 755 pkg-diff.sh ${D}/${bindir}
35 install -m 755 same-build-result.sh ${D}/${bindir}
36 install -m 755 srpm-check.sh ${D}/${bindir}
37}
38
39RDEPENDS_${PN} += "bash"