blob: 401cf1320536a7cc4f30deac9197915744dbd4b7 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "C bindings for apps which will manipulate JSON data"
2DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
3HOMEPAGE = "https://github.com/json-c/json-c/wiki"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
6
7SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \
8 file://0001-Add-FALLTHRU-comment-to-handle-GCC7-warnings.patch \
9 "
10SRC_URI[md5sum] = "55f7853f7d8cf664554ce3fa71bf1c7d"
11SRC_URI[sha256sum] = "2a136451a7932d80b7d197b10441e26e39428d67b1443ec43bbba824705e1123"
12
13UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+).tar"
14# json-c releases page is fetching the list of releases in some weird XML format
15# from https://s3.amazonaws.com/json-c_releases and processes it with javascript :-/
16#UPSTREAM_CHECK_URI = "https://s3.amazonaws.com/json-c_releases/releases/index.html"
17RECIPE_UPSTREAM_VERSION = "0.12.1"
18RECIPE_UPSTREAM_DATE = "Jun 07, 2016"
19CHECK_DATE = "Apr 19, 2017"
20
21RPROVIDES_${PN} = "libjson"
22
23inherit autotools
24
25EXTRA_OECONF = "--enable-rdrand"
26
27do_configure_prepend() {
28 # Clean up autoconf cruft that should not be in the tarball
29 rm -f ${S}/config.status
30}
31
32BBCLASSEXTEND = "native nativesdk"