blob: 3238b14face1af60febcb11bace1f04a73108f15 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = " A library providing C and Python (libcURL like) API for downloading linux repository metadata and packages."
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
4
5SRC_URI = "git://github.com/rpm-software-management/librepo.git \
6 file://0001-Correctly-set-the-library-installation-directory.patch \
7 file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
8 file://0003-tests-fix-a-race-when-deleting-temporary-directories.patch \
9 file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010 file://0005-Fix-typo-correct-LRO_SSLVERIFYHOST-with-CURLOPT_SSL_.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011 "
12
13PV = "1.7.20+git${SRCPV}"
14SRCREV = "e1137cbbda78fecb192146300790680a5bc811b1"
15
16S = "${WORKDIR}/git"
17
18DEPENDS = "curl expat glib-2.0 openssl attr libcheck gpgme"
19
20inherit cmake distutils3-base pkgconfig
21
22EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
23
24BBCLASSEXTEND = "native nativesdk"
25