blob: 3e511b6bb62ac52c20da3cb02c491bc370b20082 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Open Package Manager"
2SUMMARY_libopkg = "Open Package Manager library"
3SECTION = "base"
4HOMEPAGE = "http://code.google.com/p/opkg/"
5BUGTRACKER = "http://code.google.com/p/opkg/issues/list"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://src/opkg.c;beginline=2;endline=21;md5=90435a519c6ea69ef22e4a88bcc52fa0"
9
10DEPENDS = "libarchive"
11
12PE = "1"
13
14SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
15 file://opkg-configure.service \
16 file://opkg.conf \
17 file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
18"
19
20SRC_URI[md5sum] = "d202d09ea0932943071b842626cab13c"
21SRC_URI[sha256sum] = "734bc21dea11262113fa86b928d09812618b3966f352350cf916a6ae0d343f32"
22
23inherit autotools pkgconfig systemd
24
25SYSTEMD_SERVICE_${PN} = "opkg-configure.service"
26
27target_localstatedir := "${localstatedir}"
28OPKGLIBDIR = "${target_localstatedir}/lib"
29
30PACKAGECONFIG ??= "libsolv"
31
32PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg"
33PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
34PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl"
35PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
36PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256"
37PACKAGECONFIG[pathfinder] = "--enable-pathfinder,--disable-pathfinder,pathfinder"
38PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv"
39
40EXTRA_OECONF_class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}"
41
42do_install_append () {
43 install -d ${D}${sysconfdir}/opkg
44 install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
45 echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf
46
47 # We need to create the lock directory
48 install -d ${D}${OPKGLIBDIR}/opkg
49
50 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)};then
51 install -d ${D}${systemd_unitdir}/system
52 install -m 0644 ${WORKDIR}/opkg-configure.service ${D}${systemd_unitdir}/system/
53 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
54 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
55 -e 's,@BINDIR@,${bindir},g' \
56 -e 's,@SYSTEMD_UNITDIR@,${systemd_unitdir},g' \
57 ${D}${systemd_unitdir}/system/opkg-configure.service
58 fi
59}
60
61RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive"
62RDEPENDS_${PN}_class-native = ""
63RDEPENDS_${PN}_class-nativesdk = ""
64RREPLACES_${PN} = "opkg-nogpg opkg-collateral"
65RCONFLICTS_${PN} = "opkg-collateral"
66RPROVIDES_${PN} = "opkg-collateral"
67
68PACKAGES =+ "libopkg"
69
70FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/"
71FILES_${PN} += "${systemd_unitdir}/system/"
72
73BBCLASSEXTEND = "native nativesdk"
74
75CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf"