blob: 3f438561995b0f603fda61ff78b8fc0616a8315e [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Software Construction tool (make/autotools replacement)"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3a885dff6d14e4cd876d9008a09a42de"
5SRCNAME = "scons"
6
7SRC_URI = "https://files.pythonhosted.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
8
9SRC_URI[md5sum] = "3eac81e5e8206304a9b4683c57665aa4"
10SRC_URI[sha256sum] = "c8de85fc02ed1a687b1f2ac791eaa0c1707b4382a204f17d782b5b111b9fdf07"
11
12UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/SCons/"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18RDEPENDS_${PN} = "\
19 python-fcntl \
20 python-io \
21 python-json \
22 python-subprocess \
23 "