blob: 0efacc137af26d5318e1ac198582497c35f615c2 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require python-setuptools.inc
2
3PROVIDES = "python-distribute"
4
5DEPENDS += "python"
6DEPENDS_class-native += "python-native"
7
8inherit setuptools
9
10RDEPENDS_${PN} = "\
11 python-stringold \
12 python-email \
13 python-shell \
14 python-distutils \
15 python-compression \
16 python-pkgutil \
17 python-plistlib \
18 python-numbers \
19 python-html \
20 python-netserver \
21 python-ctypes \
22 python-subprocess \
23 python-unittest \
24 python-compile \
25"
26
27RDEPENDS_${PN}_class-native = "\
28 python-distutils \
29 python-compression \
30"
31
32RREPLACES_${PN} = "python-distribute"
33RPROVIDES_${PN} = "python-distribute"
34RCONFLICTS_${PN} = "python-distribute"
35
36BBCLASSEXTEND = "native nativesdk"