blob: bf985c44a3e19c3c47bf4d46f52f57132503c7aa [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter"
2DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \
3a back-end to a program such as ghostview, it can display PostScript and PDF \
4documents in an X11 environment. \
5\
6Furthermore, it can render PostScript and PDF files as graphics to be printed \
7on non-PostScript printers. Supported printers include common \
8dot-matrix, inkjet and laser models. \
9"
10HOMEPAGE = "http://www.ghostscript.com"
11SECTION = "console/utils"
12
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=70dc2bac4d0ce4448da873cd86b123fc"
15
16DEPENDS = "ghostscript-native tiff jpeg fontconfig cups libpng"
17DEPENDS_class-native = "libpng-native"
18
19UPSTREAM_CHECK_URI = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases"
20UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
21
22SRC_URI_BASE = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs921/${BPN}-${PV}.tar.gz \
23 file://ghostscript-9.15-parallel-make.patch \
24 file://ghostscript-9.16-Werror-return-type.patch \
25 file://do-not-check-local-libpng-source.patch \
26 file://avoid-host-contamination.patch \
27 file://mkdir-p.patch \
28"
29
30SRC_URI = "${SRC_URI_BASE} \
31 file://ghostscript-9.21-prevent_recompiling.patch \
32 file://ghostscript-9.02-genarch.patch \
33 file://objarch.h \
34 file://cups-no-gcrypt.patch \
35 file://CVE-2016-7977.patch \
36 file://CVE-2017-7207.patch \
37 file://CVE-2017-5951.patch \
38 file://CVE-2017-7975.patch \
39 file://CVE-2017-9216.patch \
40 file://CVE-2017-9611.patch \
41 file://CVE-2017-9612.patch \
42 file://CVE-2017-9739.patch \
43 file://CVE-2017-9726.patch \
44 file://CVE-2017-9727.patch \
45 file://CVE-2017-9835.patch \
46 file://CVE-2017-11714.patch \
47 "
48
49SRC_URI_class-native = "${SRC_URI_BASE} \
50 file://ghostscript-9.21-native-fix-disable-system-libtiff.patch \
51 file://base-genht.c-add-a-preprocessor-define-to-allow-fope.patch \
52 "
53
54SRC_URI[md5sum] = "5f213281761d2750fcf27476c404d17f"
55SRC_URI[sha256sum] = "02bceadbc4dddeb6f2eec9c8b1623d945d355ca11b8b4df035332b217d58ce85"
56
57# Put something like
58#
59# PACKAGECONFIG_append_pn-ghostscript = " x11"
60#
61# in local.conf to enable building with X11. Be careful. The order
62# of the overrides matters!
63#
64#PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
65PACKAGECONFIG_class-native = ""
66
67PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}, \
68 --without-x, virtual/libx11 libxext libxt gtk+3\
69 "
70
71EXTRA_OECONF = "--with-system-libtiff --without-jbig2dec \
72 --with-fontpath=${datadir}/fonts \
73 --without-libidn --with-cups-serverbin=${exec_prefix}/lib/cups \
74 --with-cups-datadir=${datadir}/cups \
75 CUPSCONFIG="${STAGING_BINDIR_CROSS}/cups-config" \
76 "
77
78EXTRA_OECONF_append_mipsarcho32 = " --with-large_color_index=0"
79
80# Explicity disable libtiff, fontconfig,
81# freetype, cups for ghostscript-native
82EXTRA_OECONF_class-native = "--without-x --with-system-libtiff=no \
83 --without-jbig2dec \
84 --with-fontpath=${datadir}/fonts \
85 --without-libidn --disable-fontconfig \
86 --disable-freetype --disable-cups"
87
88# This has been fixed upstream but for now we need to subvert the check for time.h
89# http://bugs.ghostscript.com/show_bug.cgi?id=692443
90# http://bugs.ghostscript.com/show_bug.cgi?id=692426
91CFLAGS += "-DHAVE_SYS_TIME_H=1"
92BUILD_CFLAGS += "-DHAVE_SYS_TIME_H=1"
93
94inherit autotools
95
96do_configure_prepend () {
97 mkdir -p obj
98 mkdir -p soobj
99 if [ -e ${WORKDIR}/objarch.h ]; then
100 cp ${WORKDIR}/objarch.h obj/arch.h
101 fi
102}
103
104do_configure_append () {
105 # copy tools from the native ghostscript build
106 if [ "${PN}" != "ghostscript-native" ]; then
107 mkdir -p obj/aux soobj
108 for i in genarch genconf mkromfs echogs gendev genht; do
109 cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/aux/$i
110 done
111 fi
112}
113
114do_install_append () {
115 mkdir -p ${D}${datadir}/ghostscript/${PV}/
116 cp -r ${S}/Resource ${D}${datadir}/ghostscript/${PV}/
117 cp -r ${S}/iccprofiles ${D}${datadir}/ghostscript/${PV}/
118}
119
120do_compile_class-native () {
121 mkdir -p obj
122 for i in genarch genconf mkromfs echogs gendev genht; do
123 oe_runmake obj/aux/$i
124 done
125}
126
127do_install_class-native () {
128 install -d ${D}${bindir}/ghostscript-${PV}
129 for i in genarch genconf mkromfs echogs gendev genht; do
130 install -m 755 obj/aux/$i ${D}${bindir}/ghostscript-${PV}/$i
131 done
132}
133
134BBCLASSEXTEND = "native"
135
136# ghostscript does not supports "arc"
137COMPATIBLE_HOST = "^(?!arc).*"