blob: 39cfce992f84ca3ad192beb4ffd7d3be3200509b [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require ${BPN}.inc
2
3SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
4 file://replace_glibc_check_with_linux.patch \
5 file://disable-asm-on-non-gcc.patch \
6 file://0001-Use-wayland-scanner-in-the-path.patch \
7 file://0002-hardware-gloat.patch \
8 file://vulkan-mkdir.patch \
9 file://llvm-config-version.patch \
10 file://0001-ac-fix-build-after-LLVM-5.0-SVN-r300718.patch \
11 file://0002-gallivm-Fix-build-against-LLVM-SVN-r302589.patch \
12 file://0001-winsys-svga-drm-Include-sys-types.h.patch \
13 file://0001-configure.ac-Always-check-for-expat.patch \
14 file://0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch \
15 "
16SRC_URI[md5sum] = "e40bb428a263bd28cbf6478dae45b207"
17SRC_URI[sha256sum] = "69f472a874b1122404fa0bd13e2d6bf87eb3b9ad9c21d2f39872a96d83d9e5f5"
18
19#because we cannot rely on the fact that all apps will use pkgconfig,
20#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
21do_install_append() {
22 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
23 sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
24 fi
25}