blob: a21babeb09969d71daa3ab5f9c837517ba62f5c4 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Library to handle input devices in Wayland compositors"
2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
3SECTION = "libs"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=2184aef38ff137ed33ce9a63b9d1eb8f"
7
8DEPENDS = "libevdev udev mtdev"
9
10SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \
11 file://0001-tools-Fix-race-in-autotools-install.patch \
12"
13
14SRC_URI[md5sum] = "8247f0bb67052ffb272c50c3cb9c5998"
15SRC_URI[sha256sum] = "e3590a9037e561a5791c8bd3b34bfd30fad5cacd8cbefc0d75fafe3a41d07147"
16
17inherit autotools pkgconfig lib_package
18
19PACKAGECONFIG ??= ""
20PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
21PACKAGECONFIG[libwacom] = "--enable-libwacom,--disable-libwacom,libwacom"
22PACKAGECONFIG[gui] = "--enable-debug-gui,--disable-debug-gui,cairo gtk+3"
23
24UDEVDIR = "`pkg-config --variable=udevdir udev`"
25
26EXTRA_OECONF += "--with-udev-dir=${UDEVDIR} --disable-documentation --disable-tests"
27
28# package name changed in 1.8.1 upgrade: make sure package upgrades work
29RPROVIDES_${PN} = "libinput"
30RREPLACES_${PN} = "libinput"
31RCONFLICTS_${PN} = "libinput"