blob: b9396b6c75a2ac3918962a61d50662732abead60 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
11 file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
12
13DEPENDS = "expat libxml2 libffi wayland-native"
14
15SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
16 "
17SRC_URI[md5sum] = "cae152ed956da6de53f9727bc1c45039"
18SRC_URI[sha256sum] = "69b052c031a61e89af7cc8780893d0da1e301492352aa449dee9345043e6fe51"
19
20inherit autotools pkgconfig
21
22EXTRA_OECONF = "--disable-documentation --with-host-scanner"
23EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries"
24
25# Wayland installs a M4 macro for other projects to use, which uses the target
26# pkg-config to find files. Replace pkg-config with pkg-config-native.
27do_install_append_class-native() {
28 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
29 -e 's,$PKG_CONFIG,pkg-config-native,g' \
30 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
31}
32
33sysroot_stage_all_append_class-target () {
34 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
35 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
36}
37
38FILES_${PN} = "${libdir}/*${SOLIBS}"
39FILES_${PN}-dev += "${bindir} ${datadir}/wayland"
40
41BBCLASSEXTEND = "native nativesdk"