blob: fabf0f554bbf496e4964aa6fe85efb4b4a1150c4 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001KBRANCH ?= "standard/base"
2
3require recipes-kernel/linux/linux-yocto.inc
4
5# board specific branches
6KBRANCH_qemuarm ?= "standard/arm-versatile-926ejs"
7KBRANCH_qemuarm64 ?= "standard/qemuarm64"
8KBRANCH_qemumips ?= "standard/mti-malta32"
9KBRANCH_qemuppc ?= "standard/qemuppc"
10KBRANCH_qemux86 ?= "standard/base"
11KBRANCH_qemux86-64 ?= "standard/base"
12KBRANCH_qemumips64 ?= "standard/mti-malta64"
13
Brad Bishop00111322018-04-01 22:23:53 -040014SRCREV_machine_qemuarm ?= "42cf4d6a1bc84b90681cb82ad95c129387d76b4b"
15SRCREV_machine_qemuarm64 ?= "60b649971940737dc7e3a7f247c62ffbd7c82e4c"
16SRCREV_machine_qemumips ?= "571315a5526b9e22262cf99bae7c0dd6e5bd204c"
17SRCREV_machine_qemuppc ?= "60b649971940737dc7e3a7f247c62ffbd7c82e4c"
18SRCREV_machine_qemux86 ?= "60b649971940737dc7e3a7f247c62ffbd7c82e4c"
19SRCREV_machine_qemux86-64 ?= "60b649971940737dc7e3a7f247c62ffbd7c82e4c"
20SRCREV_machine_qemumips64 ?= "e7889ba18f060368d4ab35e70b076728d73ba622"
21SRCREV_machine ?= "60b649971940737dc7e3a7f247c62ffbd7c82e4c"
22SRCREV_meta ?= "4f825eeb783a279216ee45ed3b9a63dd6837f7d7"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023
24SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;name=machine;branch=${KBRANCH}; \
25 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"
26
27LINUX_VERSION ?= "4.12.20"
28
29PV = "${LINUX_VERSION}+git${SRCPV}"
30
31KMETA = "kernel-meta"
32KCONF_BSP_AUDIT_LEVEL = "2"
33
34KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"
35
36COMPATIBLE_MACHINE = "qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
37
38# Functionality flags
39KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
40KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
41KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc"
42KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
43KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
44KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"