blob: ebee6f808ff81a4f7238ae7f8c17afcf64290ef0 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4
5CVE_PRODUCT = "libtiff"
6
7SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
8 file://libtool2.patch \
9 file://CVE-2017-9147.patch \
10 file://CVE-2017-9936.patch \
11 file://CVE-2017-10688.patch \
12 file://CVE-2017-11335.patch \
13 file://CVE-2017-13726.patch \
14 file://CVE-2017-13727.patch \
15 "
16
17SRC_URI[md5sum] = "2a7d1c1318416ddf36d5f6fa4600069b"
18SRC_URI[sha256sum] = "59d7a5a8ccd92059913f246877db95a2918e6c04fb9d43fd74e5c3390dac2910"
19
20# exclude betas
21UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
22
Brad Bishop00111322018-04-01 22:23:53 -040023inherit autotools multilib_header
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024
25CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
26
27PACKAGECONFIG ?= "cxx jpeg zlib lzma \
28 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
29
30PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
31PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
32PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
33PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
34
35# Convert single-strip uncompressed images to multiple strips of specified
36# size (default: 8192) to reduce memory usage
37PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
38
39# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
40PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
41
42# Control picking up YCbCr subsample info. Disable to support files lacking
43# the tag
44PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
45
46# Support a mechanism allowing reading large strips (usually one strip files)
47# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
48PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
49
50PACKAGES =+ "tiffxx tiff-utils"
51FILES_tiffxx = "${libdir}/libtiffxx.so.*"
52FILES_tiff-utils = "${bindir}/*"
53
Brad Bishop00111322018-04-01 22:23:53 -040054do_install_append() {
55 oe_multilib_header tiffconf.h
56}
57
Brad Bishopd7bf8c12018-02-25 22:55:05 -050058BBCLASSEXTEND = "native"