blob: 70b6e91347b3a941366de143e205ef4e7b55b255 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap"
2DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \
3bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \
4and copying files using the block map. The idea is that large file containing \
5unused blocks, like raw system image files, can be copied or flashed a lot \
6faster with bmaptool than with traditional tools like "dd" or "cp"."
7HOMEPAGE = "https://github.com/01org/bmap-tools"
8SECTION = "console/utils"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12SRC_URI = "git://github.com/intel/bmap-tools.git"
13SRCREV = "9dad724104df265442226972a1e310813f9ffcba"
14
15S = "${WORKDIR}/git"
16
17RDEPENDS_${PN} = "python3-core python3-compression python3-mmap python3-setuptools"
18
19inherit python3native
20inherit setuptools3
21
22BBCLASSEXTEND = "native"