blob: bae943ea1e60bd134cc3f216faa857b676e1410c [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001# yocto-bsp-filename {{ if kernel_choice == "linux-yocto-tiny_4.10": }} this
2FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3
4PR := "${PR}.1"
5
6COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
7
8{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
9
10{{ if need_new_kbranch == "y": }}
11{{ input type:"choicelist" name:"new_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard/tiny" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/tiny/base" }}
12
13{{ if need_new_kbranch == "n": }}
14{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard/tiny" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/tiny/base" }}
15
16{{ if need_new_kbranch == "n": }}
17KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
18
19{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}}
20{{ if smp == "y": }}
21KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
22
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023SRC_URI += "file://{{=machine}}.scc \
24 file://{{=machine}}.cfg \
25 file://{{=machine}}-tiny.scc \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026 file://{{=machine}}-user-config.cfg \
27 file://{{=machine}}-user-patches.scc \
28 file://{{=machine}}-user-features.scc \
29 "
30
31# replace these SRCREVs with the real commit ids once you've had
32# the appropriate changes committed to the upstream linux-yocto repo
33SRCREV_machine_pn-linux-yocto-tiny_{{=machine}} ?= "${AUTOREV}"
34SRCREV_meta_pn-linux-yocto-tiny_{{=machine}} ?= "${AUTOREV}"
35#LINUX_VERSION = "4.10"
36#Remove the following line once AUTOREV is locked to a certain SRCREV
37KERNEL_VERSION_SANITY_SKIP = "1"