blob: 22ed27381187188c8f732b2de0f356e6ff5220f8 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# yocto-bsp-filename {{ if kernel_choice == "linux-yocto-dev": }} this
2FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3
4PR := "${PR}.1"
5
6COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
7{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
8
9{{ if need_new_kbranch == "y": }}
10{{ input type:"choicelist" name:"new_kbranch" nameappend:"i386" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }}
11
12{{ if need_new_kbranch == "n": }}
13{{ input type:"choicelist" name:"existing_kbranch" nameappend:"i386" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }}
14
15{{ if need_new_kbranch == "n": }}
16KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
17
18{{ input type:"boolean" name:"smp" prio:"30" msg:"Would you like SMP support? (y/n)" default:"y"}}
19{{ if smp == "y": }}
20KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
21
Brad Bishopd7bf8c12018-02-25 22:55:05 -050022SRC_URI += "file://{{=machine}}.scc \
23 file://{{=machine}}.cfg \
24 file://{{=machine}}-standard.scc \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025 file://{{=machine}}-user-config.cfg \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026 file://{{=machine}}-user-features.scc \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050027 file://{{=machine}}-user-patches.scc \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050028 "