blob: b614346aff6cc1e8fa105c40998c534952d71f4d [file] [log] [blame]
Ed Tanous9eeb80f2020-08-17 15:16:39 -07001#This is largely to improve our build times by not building or installing
2#modules that OpenBMC does not use by our coding standard. Another thing to
3#note is that for most targets, coroutine and context libraries are also added
4#with a BOOST_LIBS_append_<platform> for most targets. Chrono/Thread should not
5#be relied directly, but are required dependencies of context and coroutine.
6#See the relevant portion of the openbmc coding standard with regards to boost
7#libraries
8#
9#https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost
10#
Andrew Geissler36fe5df2020-10-19 10:10:53 -050011#BOOST_LIBS_openbmc-phosphor = "chrono thread"
Ed Tanous9eeb80f2020-08-17 15:16:39 -070012