blob: dabc4a8a6be905c70f84f0811ad145fd1c4e7c19 [file] [log] [blame]
Brad Bishop5f9be072016-06-27 14:53:52 -04001SUMMARY = "org.openbmc.control.Host implementation for OpenPOWER"
2DESCRIPTION = "A host control implementation suitable for OpenPOWER systems."
3PR = "r1"
4
5inherit skeleton-gdbus
Brad Bishop1d525fa2016-08-17 20:27:37 -04006inherit obmc-phosphor-dbus-service
Brad Bishop5f9be072016-06-27 14:53:52 -04007
8SKELETON_DIR = "op-hostctl"
Brad Bishop1d525fa2016-08-17 20:27:37 -04009
10FMT = "org.openbmc.control.Host@{0}.service"
11DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
12SYSTEMD_SERVICE_${PN} = "op-start-host@.service"
13
14START_TMPL = "op-start-host@.service"
15START_TGTFMT = "obmc-chassis-start@{1}.target"
16START_INSTFMT = "obmc-start-host@{0}.service"
17START_FMT = "../${START_TMPL}:${START_TGTFMT}.wants/${START_INSTFMT}"
18
19SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"