blob: c94f5c3d123979d7e8351988fe75b9ad184ebb1b [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7e51a5677b22b865abbfb3dff6ffb2d0"
5
6SRCNAME = "numpy"
7
8SRC_URI = "https://files.pythonhosted.org/packages/source/n/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
9 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
10 file://remove-build-path-in-comments.patch \
11 file://fix_shebang_f2py.patch \
Brad Bishop37a0e4d2017-12-04 01:01:44 -050012 file://d70d37b7c4aa2af3fe879a0d858c54f2aa32a725.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060013 ${CONFIGFILESURI} "
14UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/numpy/files/"
15
16CONFIGFILESURI ?= ""
17
18CONFIGFILESURI_aarch64 = " \
19 file://config.h \
20 file://_numpyconfig.h \
21"
22CONFIGFILESURI_arm = " \
23 file://config.h \
24 file://numpyconfig.h \
25"
26CONFIGFILESURI_armeb = " \
27 file://config.h \
28 file://numpyconfig.h \
29"
30CONFIGFILESURI_mipsel = " \
31 file://config.h \
32 file://numpyconfig.h \
33"
34CONFIGFILESURI_x86 = " \
35 file://config.h \
36 file://numpyconfig.h \
37"
38CONFIGFILESURI_x86-64 = " \
39 file://config.h \
40 file://_numpyconfig.h \
41"
42CONFIGFILESURI_mips = " \
43 file://config.h \
44 file://_numpyconfig.h \
45"
46CONFIGFILESURI_powerpc = " \
47 file://config.h \
48 file://_numpyconfig.h \
49"
50CONFIGFILESURI_powerpc64 = " \
51 file://config.h \
52 file://_numpyconfig.h \
53"
54CONFIGFILESURI_mips64 = " \
55 file://config.h \
56 file://_numpyconfig.h \
57"
58CONFIGFILESURI_mips64n32 = " \
59 file://config.h \
60 file://_numpyconfig.h \
61"
62
63S = "${WORKDIR}/numpy-${PV}"
64
65inherit setuptools
66
67# Make the build fail and replace *config.h with proper one
68# This is a ugly, ugly hack - Koen
69do_compile_prepend_class-target() {
70 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
71 true
72 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
73}
74
75FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
76
77SRC_URI[md5sum] = "2f44a895a8104ffac140c3a70edbd450"
78SRC_URI[sha256sum] = "dc4082c43979cc856a2bf352a8297ea109ccb3244d783ae067eb2ee5b0d577cd"
79
80# install what is needed for numpy.test()
81RDEPENDS_${PN} = "python-unittest \
82 python-difflib \
83 python-pprint \
84 python-pickle \
85 python-shell \
86 python-nose \
87 python-doctest \
88 python-datetime \
89 python-distutils \
90 python-misc \
91 python-mmap \
92 python-netclient \
93 python-numbers \
94 python-pydoc \
95 python-pkgutil \
96 python-email \
97 python-subprocess \
98 python-compression \
99 python-ctypes \
100 python-threading \
101"
102
103RDEPENDS_${PN}_class-native = ""
104
105BBCLASSEXTEND = "native nativesdk"