Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "A multi-platform support library with a focus on asynchronous I/O" |
| 2 | HOMEPAGE = "https://github.com/libuv/libuv" |
| 3 | DESCRIPTION = "libuv is a multi-platform support library with a focus on asynchronous I/O. It was primarily developed for use by Node.js, but it's also used by Luvit, Julia, pyuv, and others." |
| 4 | BUGTRACKER = "https://github.com/libuv/libuv/issues" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ad93ca1fffe931537fcf64f6fcce084d" |
| 7 | |
| 8 | SRCREV = "e8b7eb6908a847ffbe6ab2eec7428e43a0aa53a2" |
| 9 | SRC_URI = "git://github.com/libuv/libuv;branch=v1.x;protocol=https" |
| 10 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | inherit autotools |
| 15 | |
| 16 | do_configure() { |
| 17 | ${S}/autogen.sh || bbnote "${PN} failed to autogen.sh" |
| 18 | oe_runconf |
| 19 | } |
| 20 | |
| 21 | BBCLASSEXTEND = "native" |