Adriana Kobylak | e44af88 | 2018-09-21 10:09:36 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor IPMI plugin for the Host I/O Mapping Protocol" |
| 2 | HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-flash" |
| 3 | PR = "r1" |
| 4 | PV = "0.1+git${SRCPV}" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ff331e820fda701d36a8f0efc98adc58" |
| 7 | |
| 8 | inherit autotools pkgconfig |
| 9 | inherit obmc-phosphor-ipmiprovider-symlink |
| 10 | |
| 11 | DEPENDS += "phosphor-ipmi-host" |
| 12 | DEPENDS += "autoconf-archive-native" |
Patrick Williams | 46072e3 | 2020-04-06 09:13:05 -0500 | [diff] [blame] | 13 | DEPENDS += "sdbusplus" |
Adriana Kobylak | e44af88 | 2018-09-21 10:09:36 -0500 | [diff] [blame] | 14 | DEPENDS += "phosphor-logging" |
| 15 | DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native" |
| 16 | DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native" |
| 17 | |
| 18 | TARGET_CFLAGS += "-fpic" |
| 19 | |
| 20 | HOSTIPMI_PROVIDER_LIBRARY += "libhiomap.so" |
| 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-flash" |
Andrew Geissler | a67bcfd | 2020-04-10 01:30:51 +0000 | [diff] [blame] | 25 | SRCREV = "a182dce8b97c4ca17832b4cc47c7a7b947291466" |
Adriana Kobylak | e44af88 | 2018-09-21 10:09:36 -0500 | [diff] [blame] | 26 | |
| 27 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 28 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 29 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |