blob: f0d54ea54bf6294f45b858c60340bccda3c28f89 [file] [log] [blame]
Adriana Kobylake44af882018-09-21 10:09:36 -05001SUMMARY = "Phosphor IPMI plugin for the Host I/O Mapping Protocol"
2HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-flash"
3PR = "r1"
4PV = "0.1+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=ff331e820fda701d36a8f0efc98adc58"
7
8inherit autotools pkgconfig
9inherit obmc-phosphor-ipmiprovider-symlink
10
11DEPENDS += "phosphor-ipmi-host"
12DEPENDS += "autoconf-archive-native"
Patrick Williams46072e32020-04-06 09:13:05 -050013DEPENDS += "sdbusplus"
Adriana Kobylake44af882018-09-21 10:09:36 -050014DEPENDS += "phosphor-logging"
15DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
16DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
17
18TARGET_CFLAGS += "-fpic"
19
20HOSTIPMI_PROVIDER_LIBRARY += "libhiomap.so"
21
22S = "${WORKDIR}/git"
23
24SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-flash"
Andrew Geisslera67bcfd2020-04-10 01:30:51 +000025SRCREV = "a182dce8b97c4ca17832b4cc47c7a7b947291466"
Adriana Kobylake44af882018-09-21 10:09:36 -050026
27FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
28FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
29FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"