blob: c9081c8cbbe1cefbabaa794bbbcc5327c15e8479 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "ASGI is a standard for Python asynchronous web apps and servers to communicate with each other, and positioned as an asynchronous successor to WSGI."
2HOMEPAGE = "https://pypi.org/project/asgiref/"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=f09eb47206614a4954c51db8a94840fa"
6
7SRC_URI += "file://run-ptest \
8 "
9
Patrick Williamsb542dec2023-06-09 01:26:37 -050010SRC_URI[sha256sum] = "9e0ce3aa93a819ba5b45120216b23878cf6e8525eb3848653452b4192b92afed"
Andrew Geissler517393d2023-01-13 08:55:19 -060011
12export BUILD_SYS
13export HOST_SYS
14
15inherit pypi ptest setuptools3
16
17RDEPENDS:${PN}-ptest += " \
18 ${PYTHON_PN}-pytest \
19 ${PYTHON_PN}-asyncio \
20 ${PYTHON_PN}-io \
21 ${PYTHON_PN}-multiprocessing \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}
28
29BBCLASSEXTEND = "native nativesdk"