blob: b361eef1351f1c1f9890283e555970c43ef7cfbe [file] [log] [blame]
Patrick Williams8b8bc412016-08-17 15:02:23 -05001FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
Brad Bishop3a5fbf52017-12-04 02:17:07 -05003SRC_URI_append_rpi = " \
4 file://xorg.conf.d/98-pitft.conf \
5 file://xorg.conf.d/99-calibration.conf \
6"
Patrick Williams8b8bc412016-08-17 15:02:23 -05007
8do_install_append_rpi () {
Brad Bishop3a5fbf52017-12-04 02:17:07 -05009 PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
10 if [ "${PITFT}" = "1" ]; then
11 install -d ${D}/${sysconfdir}/X11/xorg.conf.d/
12 install -m 0644 ${WORKDIR}/xorg.conf.d/98-pitft.conf ${D}/${sysconfdir}/X11/xorg.conf.d/
13 install -m 0644 ${WORKDIR}/xorg.conf.d/99-calibration.conf ${D}/${sysconfdir}/X11/xorg.conf.d/
14 fi
Patrick Williams8b8bc412016-08-17 15:02:23 -050015}
16
17FILES_${PN}_rpi += "${sysconfdir}/X11/xorg.conf ${sysconfdir}/X11/xorg.conf.d/*"