blob: 6f35e39bf39828c27134409f737cfeb655aece68 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Guess OpenSSL include path"
2SECTION = "libs"
3LICENSE = "Artistic-1.0 | GPL-1.0+"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=ea914cc2718e8d53bd7744d96e66c03c"
5
6SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-Guess-${PV}.tar.gz "
7
Andrew Geissler32b11992021-03-31 13:37:05 -05008SRC_URI[md5sum] = "9e86baf96828a38c967003a5e66f0c39"
9SRC_URI[sha256sum] = "0a18d18768cf42b49b15c9dea626199dc74346bbbc76acd3d817b9c1d2bd471d"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010
11DEPENDS += "openssl"
12
Brad Bishop15ae2502019-06-18 21:44:24 -040013RDEPENDS_${PN} = "\
14 perl-module-config \
15 perl-module-exporter \
16 perl-module-extutils-mm \
17 perl-module-extutils-mm-unix \
18 perl-module-file-spec \
19 perl-module-symbol \
20 perl-module-strict \
21 perl-module-warnings \
22"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023
24EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'"
25
26S = "${WORKDIR}/Crypt-OpenSSL-Guess-${PV}"
27
Brad Bishop15ae2502019-06-18 21:44:24 -040028inherit cpan ptest-perl
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029
30BBCLASSEXTEND = "native"
Brad Bishop15ae2502019-06-18 21:44:24 -040031
32# for backwards compatibility
33PROVIDES_${PN} += "libcrypt-openssl-guess"
34
35RDEPENDS_${PN}-ptest += "\
36 perl-module-test-more \
37"