blob: 73ef88bd9e4536d0fa8aeb6ad7e73109f6a4be25 [file] [log] [blame]
Lancelot Kao775cc0a2021-02-22 22:48:15 -06001SUMMARY = "Power Cycle by Hotswap Controller"
2DESCRIPTION = "Power Cycle by Hotswap Controller Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050010RDEPENDS:${PN} += "bash"
Lancelot Kao775cc0a2021-02-22 22:48:15 -060011
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050012FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
Ashwin Murali3ae65c92022-03-23 16:27:34 -050013SRC_URI += " file://hotswap-power-cycle.service"
Lancelot Kao775cc0a2021-02-22 22:48:15 -060014
15do_install() {
16 install -d ${D}${systemd_unitdir}/system/
17 install -m 0644 ${WORKDIR}/hotswap-power-cycle.service ${D}${systemd_unitdir}/system/hotswap-power-cycle.service
18}
19
20SYSTEMD_PACKAGES = "${PN}"
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050021SYSTEMD_SERVICE:${PN} = " hotswap-power-cycle.service"