blob: 98d05f6e255c0e7378ea41d5f8267b33585e7c8f [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Improved drop-in replacement for std::function"
2DESCRIPTION = "Provides improved implementations of std::function."
3HOMEPAGE = "https://naios.github.io/function2"
4LICENSE = "BSL-1.0"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
6SRCREV = "a354bd093d2b6e50c9325dbce84d20b4e77aabc6"
Patrick Williams73bd93f2024-02-20 08:07:48 -06007PV .= "+git"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06008
9SRC_URI += "gitsm://github.com/Naios/function2;branch=master;protocol=https"
10
11S = "${WORKDIR}/git"
12
13inherit cmake
14inherit ptest
15
16# Installs some data to incorrect top-level /usr directory
17do_install:append() {
18 mkdir -p ${D}/${datadir}/function2
19 mv ${D}/${prefix}/Readme.md ${D}/${datadir}/function2/
20 mv ${D}/${prefix}/LICENSE.txt ${D}/${datadir}/function2/
21}