Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Checksumming Copy on Write Filesystem utilities" |
| 2 | DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \ |
| 3 | implementing advanced features while focusing on fault tolerance, repair and \ |
| 4 | easy administration. \ |
| 5 | This package contains utilities (mkfs, fsck, btrfsctl) used to work with \ |
| 6 | btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3." |
| 7 | |
| 8 | HOMEPAGE = "https://btrfs.wiki.kernel.org" |
| 9 | |
| 10 | LICENSE = "GPL-2.0-only & LGPL-2.1-or-later" |
| 11 | LIC_FILES_CHKSUM = " \ |
| 12 | file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067 \ |
| 13 | file://libbtrfsutil/COPYING;md5=4fbd65380cdd255951079008b364516c \ |
| 14 | " |
| 15 | SECTION = "base" |
| 16 | DEPENDS = "lzo util-linux zlib" |
| 17 | |
| 18 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git;branch=master \ |
| 19 | file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \ |
| 20 | " |
| 21 | SRCREV = "31458c9c81935abbed010221261897273a98d2c1" |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | PACKAGECONFIG ??= " \ |
| 25 | programs \ |
| 26 | convert \ |
| 27 | python \ |
| 28 | crypto-builtin \ |
| 29 | " |
| 30 | PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native" |
| 31 | PACKAGECONFIG[programs] = "--enable-programs,--disable-programs" |
| 32 | PACKAGECONFIG[convert] = "--enable-convert --with-convert=ext2,--disable-convert --without-convert,e2fsprogs" |
| 33 | PACKAGECONFIG[zoned] = "--enable-zoned,--disable-zoned" |
| 34 | PACKAGECONFIG[python] = "--enable-python,--disable-python,python3-setuptools-native" |
| 35 | PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd" |
| 36 | PACKAGECONFIG[udev] = "--enable-libudev,--disable-libudev,udev" |
| 37 | |
| 38 | # Pick only one crypto provider |
| 39 | PACKAGECONFIG[crypto-builtin] = "--with-crypto=builtin" |
| 40 | PACKAGECONFIG[crypto-libgcrypt] = "--with-crypto=libgcrypt,,libgcrypt" |
| 41 | PACKAGECONFIG[crypto-libsodium] = "--with-crypto=libsodium,,libsodium" |
| 42 | PACKAGECONFIG[crypto-libkcapi] = "--with-crypto=libkcapi,,libkcapi" |
| 43 | |
| 44 | inherit autotools-brokensep pkgconfig manpages |
| 45 | inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'setuptools3-base', '', d)} |
| 46 | |
| 47 | CLEANBROKEN = "1" |
| 48 | |
| 49 | EXTRA_OECONF = "--enable-largefile" |
| 50 | EXTRA_OECONF:append:libc-musl = " --disable-backtrace " |
| 51 | EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}" |
| 52 | EXTRA_PYTHON_CFLAGS:class-native = "" |
| 53 | EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}" |
| 54 | EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'" |
| 55 | |
| 56 | do_configure:prepend() { |
| 57 | # Upstream doesn't ship this and autoreconf won't install it as automake isn't used. |
| 58 | mkdir -p ${S}/config |
| 59 | cp -f $(automake --print-libdir)/install-sh ${S}/config/ |
| 60 | } |
| 61 | |
| 62 | |
| 63 | do_install:append() { |
| 64 | if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then |
| 65 | oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python |
| 66 | fi |
| 67 | } |
| 68 | |
| 69 | RDEPENDS:${PN} = "libgcc" |
| 70 | |
| 71 | BBCLASSEXTEND = "native nativesdk" |