blob: cdc3f9b584c5008c264a34922181f02b40742de0 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "https://www.webkitgtk.org/"
3BUGTRACKER = "https://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
9 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
10 "
11
12SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 file://0001-Fix-racy-parallel-build-of-WebKit2-4.0.gir.patch \
16 file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \
17 file://0001-Enable-THREADS_PREFER_PTHREAD_FLAG.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050018 file://0001-Fix-build-with-musl.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060019 file://include_xutil.patch \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050020 file://reduce-memory-overheads.patch \
21 file://0001-Extend-atomics-check-to-include-1-byte-CAS-test.patch \
22 file://musl-lower-stack-usage.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050023 "
Andrew Geissler95ac1b82021-03-31 14:34:31 -050024
Andrew Geissler90fd73c2021-03-05 15:25:55 -060025SRC_URI[sha256sum] = "7d0dab08e3c5ae07bec80b2822ef42e952765d5724cac86eb23999bfed5a7f1f"
Andrew Geissler82c905d2020-04-13 13:39:40 -050026
27inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gtk-doc
28
29ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
30REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'opengl', '', d)}"
31
32CVE_PRODUCT = "webkitgtk webkitgtk\+"
33
34DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libgcrypt \
35 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
36 pango icu bison-native gawk intltool-native libwebp \
37 atk udev harfbuzz jpeg libpng librsvg libtheora libvorbis \
38 ruby-native libnotify gstreamer1.0-plugins-bad \
39 gettext-native glib-2.0 glib-2.0-native libtasn1 \
40 "
41
Andrew Geissler6ce62a22020-11-30 19:58:47 -060042PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050043 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \
44 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'webgl gles2', d)} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050045 enchant \
46 libsecret \
47 "
48
49PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland libwpe wpebackend-fdo wayland-native"
50PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11 libxcomposite libxdamage libxrender libxt"
51PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
52PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2"
53PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
54PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060055PACKAGECONFIG[opengl] = "-DENABLE_GRAPHICS_CONTEXT_GL=ON,-DENABLE_GRAPHICS_CONTEXT_GL=OFF,virtual/libgl"
Andrew Geissler82c905d2020-04-13 13:39:40 -050056PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret"
57PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
58PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2"
59PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060060PACKAGECONFIG[systemd] = "-DUSE_SYSTEMD=ON,-DUSE_SYSTEMD=off,systemd"
Andrew Geissler95ac1b82021-03-31 14:34:31 -050061PACKAGECONFIG[reduce-size] = "-DCMAKE_BUILD_TYPE=MinSizeRel,-DCMAKE_BUILD_TYPE=Release,,"
Andrew Geissler82c905d2020-04-13 13:39:40 -050062
63# webkitgtk is full of /usr/bin/env python, particular for generating docs
64do_configure[postfuncs] += "setup_python_link"
65setup_python_link() {
66 if [ ! -e ${STAGING_BINDIR_NATIVE}/python ]; then
67 ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python
68 fi
69}
70
71EXTRA_OECMAKE = " \
72 -DPORT=GTK \
Andrew Geissler82c905d2020-04-13 13:39:40 -050073 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
74 ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \
75 -DENABLE_MINIBROWSER=ON \
76 -DPYTHON_EXECUTABLE=`which python3` \
77 -DENABLE_BUBBLEWRAP_SANDBOX=OFF \
78 "
79
80# Javascript JIT is not supported on ARC
81EXTRA_OECMAKE_append_arc = " -DENABLE_JIT=OFF "
82# By default 25-bit "medium" calls are used on ARC
83# which is not enough for binaries larger than 32 MiB
84CFLAGS_append_arc = " -mlong-calls"
85CXXFLAGS_append_arc = " -mlong-calls"
86
87# Javascript JIT is not supported on powerpc
88EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
89EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
90
91# ARM JIT code does not build on ARMv4/5/6 anymore
92EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
93EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
94EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF "
95
96EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF "
97EXTRA_OECMAKE_append_powerpc = " -DUSE_LD_GOLD=OFF "
98
Andrew Geissler6ce62a22020-11-30 19:58:47 -060099# JIT and gold linker does not work on RISCV
100EXTRA_OECMAKE_append_riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
101EXTRA_OECMAKE_append_riscv64 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
102
Andrew Geissler82c905d2020-04-13 13:39:40 -0500103# JIT not supported on MIPS either
104EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
105
106# JIT not supported on X32
107# An attempt was made to upstream JIT support for x32 in
108# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
109# unresolved due to limited X32 adoption.
110EXTRA_OECMAKE_append_x86-x32 = " -DENABLE_JIT=OFF "
111
112SECURITY_CFLAGS_remove_aarch64 = "-fpie"
113SECURITY_CFLAGS_append_aarch64 = " -fPIE"
114
115FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
116
117RRECOMMENDS_${PN} += "ca-certificates shared-mime-info"
118
119# http://errors.yoctoproject.org/Errors/Details/20370/
120ARM_INSTRUCTION_SET_armv4 = "arm"
121ARM_INSTRUCTION_SET_armv5 = "arm"
122ARM_INSTRUCTION_SET_armv6 = "arm"
123
124# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
125# https://bugs.webkit.org/show_bug.cgi?id=159880
126# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
127# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
128ARM_INSTRUCTION_SET_armv7a = "thumb"
129ARM_INSTRUCTION_SET_armv7r = "thumb"
130ARM_INSTRUCTION_SET_armv7ve = "thumb"
131
132# introspection inside qemu-arm hangs forever on musl/arm builds
133# therefore disable GI_DATA
134GI_DATA_ENABLED_libc-musl_armv7a = "False"
135GI_DATA_ENABLED_libc-musl_armv7ve = "False"
136
137# Can't be built with ccache
138CCACHE_DISABLE = "1"
Andrew Geissler09209ee2020-12-13 08:44:15 -0600139
140PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
141src_package_preprocess () {
142 # Trim build paths from comments in generated sources to ensure reproducibility
143 sed -i -e "s,${WORKDIR},,g" \
144 ${B}/DerivedSources/webkit2gtk/webkit2/*.cpp \
145 ${B}/DerivedSources/ForwardingHeaders/JavaScriptCore/*.h \
146 ${B}/DerivedSources/JavaScriptCore/*.h \
147 ${B}/DerivedSources/JavaScriptCore/yarr/*.h \
148 ${B}/DerivedSources/MiniBrowser/*.c
149}
150