Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | # reproducible_build.bbclass |
| 2 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 3 | # Sets SOURCE_DATE_EPOCH in each component's build environment. |
| 4 | # Upstream components (generally) respect this environment variable, |
| 5 | # using it in place of the "current" date and time. |
| 6 | # See https://reproducible-builds.org/specs/source-date-epoch/ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 7 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 8 | # After sources are unpacked but before they are patched, we set a reproducible value for SOURCE_DATE_EPOCH. |
| 9 | # This value should be reproducible for anyone who builds the same revision from the same sources. |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 10 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | # There are 4 ways we determine SOURCE_DATE_EPOCH: |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 12 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | # 1. Use the value from __source_date_epoch.txt file if this file exists. |
| 14 | # This file was most likely created in the previous build by one of the following methods 2,3,4. |
| 15 | # Alternatively, it can be provided by a recipe via SRC_URI. |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 16 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | # If the file does not exist: |
| 18 | # |
| 19 | # 2. If there is a git checkout, use the last git commit timestamp. |
| 20 | # Git does not preserve file timestamps on checkout. |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 21 | # |
| 22 | # 3. Use the mtime of "known" files such as NEWS, CHANGLELOG, ... |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | # This works for well-kept repositories distributed via tarball. |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 24 | # |
Brad Bishop | a5c52ff | 2018-11-23 10:55:50 +1300 | [diff] [blame] | 25 | # 4. Use the modification time of the youngest file in the source tree, if there is one. |
| 26 | # This will be the newest file from the distribution tarball, if any. |
| 27 | # |
| 28 | # 5. Fall back to a fixed timestamp. |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 29 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 30 | # Once the value of SOURCE_DATE_EPOCH is determined, it is stored in the recipe's SDE_FILE. |
| 31 | # If none of these mechanisms are suitable, replace the do_deploy_source_date_epoch task |
| 32 | # with recipe-specific functionality to write the appropriate SOURCE_DATE_EPOCH into the SDE_FILE. |
| 33 | # |
| 34 | # If this file is found by other tasks, the value is exported in the SOURCE_DATE_EPOCH variable. |
| 35 | # SOURCE_DATE_EPOCH is set for all tasks that might use it (do_configure, do_compile, do_package, ...) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 36 | |
| 37 | BUILD_REPRODUCIBLE_BINARIES ??= '1' |
| 38 | inherit ${@oe.utils.ifelse(d.getVar('BUILD_REPRODUCIBLE_BINARIES') == '1', 'reproducible_build_simple', '')} |
| 39 | |
| 40 | SDE_DIR ="${WORKDIR}/source-date-epoch" |
| 41 | SDE_FILE = "${SDE_DIR}/__source_date_epoch.txt" |
| 42 | |
| 43 | SSTATETASKS += "do_deploy_source_date_epoch" |
| 44 | |
| 45 | do_deploy_source_date_epoch () { |
| 46 | echo "Deploying SDE to ${SDE_DIR}." |
| 47 | } |
| 48 | |
| 49 | python do_deploy_source_date_epoch_setscene () { |
| 50 | sstate_setscene(d) |
| 51 | } |
| 52 | |
| 53 | do_deploy_source_date_epoch[dirs] = "${SDE_DIR}" |
| 54 | do_deploy_source_date_epoch[sstate-plaindirs] = "${SDE_DIR}" |
| 55 | addtask do_deploy_source_date_epoch_setscene |
| 56 | addtask do_deploy_source_date_epoch before do_configure after do_patch |
| 57 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 58 | def get_source_date_epoch_from_known_files(d, sourcedir): |
| 59 | source_date_epoch = None |
| 60 | newest_file = None |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 61 | known_files = set(["NEWS", "ChangeLog", "Changelog", "CHANGES"]) |
| 62 | for file in known_files: |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 63 | filepath = os.path.join(sourcedir, file) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 64 | if os.path.isfile(filepath): |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 65 | mtime = int(os.lstat(filepath).st_mtime) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 66 | # There may be more than one "known_file" present, if so, use the youngest one |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 67 | if not source_date_epoch or mtime > source_date_epoch: |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 68 | source_date_epoch = mtime |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 69 | newest_file = filepath |
| 70 | if newest_file: |
| 71 | bb.debug(1, "SOURCE_DATE_EPOCH taken from: %s" % newest_file) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 72 | return source_date_epoch |
| 73 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 74 | def find_git_folder(d, sourcedir): |
| 75 | # First guess: WORKDIR/git |
| 76 | # This is the default git fetcher unpack path |
| 77 | workdir = d.getVar('WORKDIR') |
| 78 | gitpath = os.path.join(workdir, "git/.git") |
| 79 | if os.path.isdir(gitpath): |
| 80 | return gitpath |
| 81 | |
| 82 | # Second guess: ${S} |
| 83 | gitpath = os.path.join(sourcedir, ".git") |
| 84 | if os.path.isdir(gitpath): |
| 85 | return gitpath |
| 86 | |
| 87 | # Perhaps there was a subpath or destsuffix specified. |
| 88 | # Go looking in the WORKDIR |
| 89 | exclude = set(["build", "image", "license-destdir", "patches", "pseudo", |
| 90 | "recipe-sysroot", "recipe-sysroot-native", "sysroot-destdir", "temp"]) |
| 91 | for root, dirs, files in os.walk(workdir, topdown=True): |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 92 | dirs[:] = [d for d in dirs if d not in exclude] |
| 93 | if '.git' in dirs: |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 94 | return root |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 95 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 96 | bb.warn("Failed to find a git repository in WORKDIR: %s" % workdir) |
| 97 | return None |
| 98 | |
| 99 | def get_source_date_epoch_from_git(d, sourcedir): |
| 100 | source_date_epoch = None |
| 101 | if "git://" in d.getVar('SRC_URI'): |
| 102 | gitpath = find_git_folder(d, sourcedir) |
| 103 | if gitpath: |
| 104 | import subprocess |
| 105 | source_date_epoch = int(subprocess.check_output(['git','log','-1','--pretty=%ct'], cwd=gitpath)) |
| 106 | bb.debug(1, "git repository: %s" % gitpath) |
| 107 | return source_date_epoch |
| 108 | |
| 109 | def get_source_date_epoch_from_youngest_file(d, sourcedir): |
Brad Bishop | a5c52ff | 2018-11-23 10:55:50 +1300 | [diff] [blame] | 110 | if sourcedir == d.getVar('WORKDIR'): |
| 111 | # These sources are almost certainly not from a tarball |
| 112 | return None |
| 113 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 114 | # Do it the hard way: check all files and find the youngest one... |
| 115 | source_date_epoch = None |
| 116 | newest_file = None |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 117 | for root, dirs, files in os.walk(sourcedir, topdown=True): |
| 118 | files = [f for f in files if not f[0] == '.'] |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 119 | |
| 120 | for fname in files: |
| 121 | filename = os.path.join(root, fname) |
| 122 | try: |
| 123 | mtime = int(os.lstat(filename).st_mtime) |
| 124 | except ValueError: |
| 125 | mtime = 0 |
| 126 | if not source_date_epoch or mtime > source_date_epoch: |
| 127 | source_date_epoch = mtime |
| 128 | newest_file = filename |
| 129 | |
| 130 | if newest_file: |
| 131 | bb.debug(1, "Newest file found: %s" % newest_file) |
| 132 | return source_date_epoch |
| 133 | |
Brad Bishop | a5c52ff | 2018-11-23 10:55:50 +1300 | [diff] [blame] | 134 | def fixed_source_date_epoch(): |
| 135 | bb.debug(1, "No tarball or git repo found to determine SOURCE_DATE_EPOCH") |
| 136 | return 0 |
| 137 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 138 | python do_create_source_date_epoch_stamp() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 139 | epochfile = d.getVar('SDE_FILE') |
| 140 | if os.path.isfile(epochfile): |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 141 | bb.debug(1, "Reusing SOURCE_DATE_EPOCH from: %s" % epochfile) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 142 | return |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 143 | |
| 144 | sourcedir = d.getVar('S') |
| 145 | source_date_epoch = ( |
| 146 | get_source_date_epoch_from_git(d, sourcedir) or |
| 147 | get_source_date_epoch_from_known_files(d, sourcedir) or |
| 148 | get_source_date_epoch_from_youngest_file(d, sourcedir) or |
Brad Bishop | a5c52ff | 2018-11-23 10:55:50 +1300 | [diff] [blame] | 149 | fixed_source_date_epoch() # Last resort |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 150 | ) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 151 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 152 | bb.debug(1, "SOURCE_DATE_EPOCH: %d" % source_date_epoch) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 153 | bb.utils.mkdirhier(d.getVar('SDE_DIR')) |
| 154 | with open(epochfile, 'w') as f: |
| 155 | f.write(str(source_date_epoch)) |
| 156 | } |
| 157 | |
| 158 | BB_HASHBASE_WHITELIST += "SOURCE_DATE_EPOCH" |
| 159 | |
| 160 | python () { |
| 161 | if d.getVar('BUILD_REPRODUCIBLE_BINARIES') == '1': |
| 162 | d.appendVarFlag("do_unpack", "postfuncs", " do_create_source_date_epoch_stamp") |
| 163 | epochfile = d.getVar('SDE_FILE') |
| 164 | source_date_epoch = "0" |
| 165 | if os.path.isfile(epochfile): |
| 166 | with open(epochfile, 'r') as f: |
| 167 | source_date_epoch = f.read() |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 168 | bb.debug(1, "SOURCE_DATE_EPOCH: %s" % source_date_epoch) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 169 | d.setVar('SOURCE_DATE_EPOCH', source_date_epoch) |
| 170 | } |