Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "XWayland is an X Server that runs under Wayland." |
| 2 | DESCRIPTION = "XWayland is an X Server running as a Wayland client, \ |
| 3 | and thus is capable of displaying native X11 client applications in a \ |
| 4 | Wayland compositor environment. The goal of XWayland is to facilitate \ |
| 5 | the transition from X Window System to Wayland environments, providing \ |
| 6 | a way to run unported applications in the meantime." |
| 7 | HOMEPAGE = "https://fedoraproject.org/wiki/Changes/XwaylandStandalone" |
| 8 | |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=5df87950af51ac2c5822094553ea1880" |
| 11 | |
| 12 | SRC_URI = "https://www.x.org/archive/individual/xserver/xwayland-${PV}.tar.xz" |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "a712eb7bce32cd934df36814b5dd046aa670899c16fe98f2afb003578f86a1c5" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 14 | |
| 15 | UPSTREAM_CHECK_REGEX = "xwayland-(?P<pver>\d+(\.(?!90\d)\d+)+)\.tar" |
| 16 | |
| 17 | inherit meson features_check pkgconfig |
| 18 | REQUIRED_DISTRO_FEATURES = "x11 opengl" |
| 19 | |
| 20 | DEPENDS += "xorgproto xtrans pixman libxkbfile libxfont2 wayland wayland-native wayland-protocols libdrm libepoxy libxcvt" |
| 21 | |
| 22 | OPENGL_PKGCONFIGS = "glx glamor dri3" |
| 23 | PACKAGECONFIG ??= "${XORG_CRYPTO} \ |
| 24 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${OPENGL_PKGCONFIGS}', '', d)} \ |
| 25 | " |
| 26 | PACKAGECONFIG[dri3] = "-Ddri3=true,-Ddri3=false" |
| 27 | PACKAGECONFIG[glx] = "-Dglx=true,-Dglx=false,virtual/libgl virtual/libx11" |
| 28 | PACKAGECONFIG[glamor] = "-Dglamor=true,-Dglamor=false,libepoxy virtual/libgbm,libegl" |
| 29 | PACKAGECONFIG[unwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind" |
| 30 | PACKAGECONFIG[xinerama] = "-Dxinerama=true,-Dxinerama=false" |
| 31 | |
| 32 | # Xorg requires a SHA1 implementation, pick one |
| 33 | XORG_CRYPTO ??= "openssl" |
| 34 | PACKAGECONFIG[openssl] = "-Dsha1=libcrypto,,openssl" |
| 35 | PACKAGECONFIG[nettle] = "-Dsha1=libnettle,,nettle" |
| 36 | PACKAGECONFIG[gcrypt] = "-Dsha1=libgcrypt,,libgcrypt" |
| 37 | |
| 38 | do_install:append() { |
| 39 | # remove files not needed and clashing with xserver-xorg |
| 40 | rm -rf ${D}/${libdir}/xorg/ |
| 41 | } |
| 42 | |
| 43 | FILES:${PN} += "${libdir}/xorg/protocol.txt" |
| 44 | |
| 45 | RDEPENDS:${PN} += "xkbcomp" |