blob: 79934e2229c7d2b14f104418afa85970ff518adc [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001# NOTE:
2# You should use perl-module-encode rather than this package
3# unless you specifically need a version newer than what is
4# provided by perl.
5
6SUMMARY = "Encode - character encodings"
7DESCRIPTION = "The \"Encode\" module provides the interfaces between \
8Perl's strings and the rest of the system. Perl strings are sequences \
9of characters."
10
11AUTHOR = "Dan Kogai <dankogai+cpan@gmail.com>"
12HOMEPAGE = "https://metacpan.org/release/Encode"
13SECTION = "lib"
14LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
15LIC_FILES_CHKSUM = "file://META.json;beginline=8;endline=10;md5=b12e3be1e17a7e99ca4f429ff32c28b5"
16
17SRC_URI = "${CPAN_MIRROR}/authors/id/D/DA/DANKOGAI/Encode-${PV}.tar.gz"
18SRC_URI[sha256sum] = "9163f848eef69e4d4cc8838397f0861fd9ea7ede001117dbd9694f8d95052ef5"
19
20UPSTREAM_CHECK_REGEX = "Encode\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
21
22S = "${WORKDIR}/Encode-${PV}"
23
Andrew Geissler3eeda902023-05-19 10:14:02 -050024#EXTRA_CPANFLAGS:append = "PERL=../recipe-sysroot-native/usr/bin/perl-native/perl"
Patrick Williams92b42cb2022-09-03 06:53:57 -050025inherit cpan ptest-perl
Patrick Williams92b42cb2022-09-03 06:53:57 -050026do_install:prepend() {
27 # Requires "-T" (taint) option on command line
28 rm -rf ${B}/t/taint.t
29 # Circular dependency of perl-module-open on perl-module-encode
30 # and we cannot load perl-module-encode because we are providing
31 # an alternative
32 rm -rf ${B}/t/use-Encode-Alias.t
33}
34
Andrew Geissler3eeda902023-05-19 10:14:02 -050035do_install:append() {
36 sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native||g" ${S}/*/*.exh ${S}/*.exh
37}
38
Patrick Williams92b42cb2022-09-03 06:53:57 -050039do_install_ptest() {
40 mkdir ${D}${PTEST_PATH}/bin
41 cp -r ${B}/bin/piconv ${D}${PTEST_PATH}/bin
42 cp -r ${B}/blib ${D}${PTEST_PATH}
43 chown -R root:root ${D}${PTEST_PATH}
44}
45
46# file /usr/bin/enc2xs from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586
47# file /usr/bin/encguess from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586
48# file /usr/bin/piconv from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586
49RCONFLICTS:${PN} = "perl-misc perl-module-encode"
50
51RDEPENDS:${PN} += " \
52 perl-module-bytes \
53 perl-module-constant \
54 perl-module-parent \
55 perl-module-storable \
56 perl-module-xsloader \
57 "
58
59RPROVIDES:${PN} += " \
60 libencode-alias-perl \
61 libencode-byte-perl \
62 libencode-cjkconstants-perl \
63 libencode-cn-perl \
64 libencode-cn-hz-perl \
65 libencode-config-perl \
66 libencode-ebcdic-perl \
67 libencode-encoder-perl \
68 libencode-encoding-perl \
69 libencode-gsm0338-perl \
70 libencode-guess-perl \
71 libencode-jp-perl \
72 libencode-jp-h2z-perl \
73 libencode-jp-jis7-perl \
74 libencode-kr-perl \
75 libencode-kr-2022_kr-perl \
76 libencode-mime-header-perl \
77 libencode-mime-name-perl \
78 libencode-symbol-perl \
79 libencode-tw-perl \
80 libencode-unicode-perl \
81 libencode-unicode-utf7-perl \
82 libencoding-perl \
83 libencode-internal-perl \
84 libencode-mime-header-iso_2022_jp-perl \
85 libencode-utf8-perl \
86 libencode-utf_ebcdic-perl \
87 "
88
89RDEPENDS:${PN}-ptest += " \
90 perl-module-blib \
91 perl-module-charnames \
92 perl-module-file-compare \
93 perl-module-file-copy \
94 perl-module-filehandle \
95 perl-module-findbin \
96 perl-module-integer \
97 perl-module-io-select \
98 perl-module-ipc-open3 \
99 perl-module-mime-base64 \
100 perl-module-perlio \
101 perl-module-perlio-encoding \
102 perl-module-perlio-scalar \
103 perl-module-test-more \
104 perl-module-tie-scalar \
105 perl-module-unicore \
106 perl-module-utf8 \
107 "
108
109BBCLASSEXTEND = "native"