blob: a3d2b741b116f2ba4c04f90bfc90a2f44d3b53aa [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The extensible, standards compliant build backend used by Hatch"
2HOMEPAGE = "https://hatch.pypa.io/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cbe2fd33fc9297692812fc94b7d27fd9"
5
6inherit pypi python_hatchling
7
Andrew Geissler3eeda902023-05-19 10:14:02 -05008DEPENDS += "python3-pluggy-native python3-pathspec-native python3-packaging-native python3-editables-native python3-trove-classifiers-native"
Andrew Geissler517393d2023-01-13 08:55:19 -06009DEPENDS:remove:class-native = "python3-hatchling-native"
10
Andrew Geissler3eeda902023-05-19 10:14:02 -050011SRC_URI[sha256sum] = "55fbc88cbd0d96c09c3e9392b51db513fd4cb4caf47615d65f935a5ef1756133"
Andrew Geissler517393d2023-01-13 08:55:19 -060012
13do_compile:prepend() {
14 export PYTHONPATH=src
15}
16
17BBCLASSEXTEND = "native nativesdk"