Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | require pcp.inc |
| 2 | inherit python3native native |
| 3 | #autotools-brokensep |
| 4 | DEPENDS = "python3-native python3-setuptools-native flex-native bison-native" |
| 5 | |
| 6 | export PCP_DIR = "${D}" |
| 7 | export PCP_TMP_DIR = "${D}/tmp" |
| 8 | export PCP_BIN_DIR = "${D}/usr/bin" |
| 9 | |
| 10 | B = "${S}" |
| 11 | |
| 12 | do_configure:prepend() { |
| 13 | export SED=${TMPDIR}/hosttools/sed |
| 14 | export AR=${TMPDIR}/hosttools/ar |
| 15 | # export PYTHON=python3 |
| 16 | |
| 17 | rm -rf ${S}/include/pcp/configsz.h |
| 18 | rm -rf ${S}/include/pcp/platformsz.h |
| 19 | |
| 20 | } |
| 21 | do_compile:prepend() { |
| 22 | sed -i -e "s,#undef HAVE_64BIT_LONG,,g" \ |
| 23 | -e "s,#undef HAVE_64BIT_PTR,,g" \ |
| 24 | -e "s,#undef PM_SIZEOF_SUSECONDS_T,,g" \ |
| 25 | -e "s,#undef PM_SIZEOF_TIME_T,,g" \ |
| 26 | ${S}/src/include/pcp/config.h.in |
| 27 | |
| 28 | export AR=${TMPDIR}/hosttools/ar |
| 29 | # export PYTHON=python3 |
| 30 | } |
| 31 | |
| 32 | do_compile() { |
| 33 | oe_runmake default_pcp |
| 34 | } |
| 35 | |
| 36 | do_install () { |
| 37 | oe_runmake install \ |
| 38 | PCP_ETC_DIR=${D}/${sysconfdir} \ |
| 39 | PCP_SYSCONF_DIR=${D}/${sysconfdir} \ |
| 40 | PCP_VAR_DIR=${D}/${localstatedir} \ |
| 41 | PCP_SHARE_DIR=${D}/${datadir} \ |
| 42 | PCP_BIN_DIR=${D}/${bindir} \ |
| 43 | PCP_BINADM_DIR=${D}/${libexecdir}/pcp/bin \ |
| 44 | PCP_LIBADM_DIR=${D}/${libdir} \ |
| 45 | PCP_LIB_DIR=${D}/${libdir} \ |
| 46 | PCP_MAN_DIR=${D}/${mandir} \ |
| 47 | PCP_DOC_DIR=${D}/${docdir} |
| 48 | } |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 49 | #| chkacc1.c:8:10: fatal error: localconfig.h: No such file or directory |
| 50 | #| 8 | #include "localconfig.h" |
| 51 | #| | ^~~~~~~~~~~~~~~ |
| 52 | PARALLEL_MAKE = "" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 53 | |