blob: 4aebf6f2410a1312215802f987abe53dde0cd63e [file] [log] [blame]
Xo Wangb13aa512016-12-15 18:29:58 -08001SUMMARY = "Zaius AVSBus control"
2DESCRIPTION = "Voltage regulator module (VRM) AVSBus control for Zaius"
3PR = "r0"
Brad Bishop71d01e22018-11-07 12:44:15 -08004LICENSE = "Apache-2.0"
Brad Bishopa242d472019-09-13 14:08:31 -04005LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Xo Wangb13aa512016-12-15 18:29:58 -08006
7inherit obmc-phosphor-systemd
Xo Wangb13aa512016-12-15 18:29:58 -08008
9TMPL_OFF = "avsbus-disable@.service"
10TMPL_ON = "avsbus-enable@.service"
11INSTFMT_OFF = "avsbus-disable@{0}.service"
12INSTFMT_ON = "avsbus-enable@{0}.service"
Josh D. Kingefb04a12017-04-06 15:56:37 -050013TGTFMT_OFF = "obmc-host-stop@{0}.target"
Josh D. Kingb9ee5362017-04-06 14:43:46 -050014TGTFMT_ON = "obmc-chassis-poweron@{0}.target"
Xo Wangb13aa512016-12-15 18:29:58 -080015FMT_OFF = "../${TMPL_OFF}:${TGTFMT_OFF}.wants/${INSTFMT_OFF}"
Matt Spinler3dfd7e82017-03-30 08:38:28 -050016FMT_ON = "../${TMPL_ON}:${TGTFMT_ON}.requires/${INSTFMT_ON}"
Xo Wangb13aa512016-12-15 18:29:58 -080017
Brandon Kim40d8f442021-08-11 13:22:32 -070018SYSTEMD_SERVICE:${PN} += "${TMPL_OFF}"
Xo Wangb13aa512016-12-15 18:29:58 -080019SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_OFF', 'OBMC_CHASSIS_INSTANCES')}"
Brandon Kim40d8f442021-08-11 13:22:32 -070020SYSTEMD_SERVICE:${PN} += "${TMPL_ON}"
Xo Wangb13aa512016-12-15 18:29:58 -080021SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_ON', 'OBMC_CHASSIS_INSTANCES')}"
22
23SRC_URI += "file://zaius_avsbus.sh"
Brandon Kim40d8f442021-08-11 13:22:32 -070024RDEPENDS:${PN} += "i2c-tools"
Xo Wangb13aa512016-12-15 18:29:58 -080025
26do_install() {
27 install -d ${D}${bindir}
28 install -m 0755 ${WORKDIR}/zaius_avsbus.sh ${D}${bindir}/zaius_avsbus.sh
29}