blob: 842a9772cbe436a75ca492d742b0bcf1e9f9820c [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
2
3LICENSE = "MIT"
4
5SRC_URI = "file://hello.c \
6 file://gdb.sh \
7"
8
9S = "${WORKDIR}"
10
11do_compile () {
12 ${CC} hello.c -o hello1 ${CFLAGS} ${LDFLAGS}
13}
14
15do_install () {
16 install -d ${D}${bindir}
17 install -m 755 ${WORKDIR}/gdb.sh ${D}${bindir}/
18 install -m 755 hello1 ${D}${bindir}/hello1
19 ln ${D}${bindir}/hello1 ${D}${bindir}/hello2
20
21 install -d ${D}${libexecdir}
22 ln ${D}${bindir}/hello1 ${D}${libexecdir}/hello3
23 ln ${D}${bindir}/hello1 ${D}${libexecdir}/hello4
24
25 dd if=/dev/zero of=${D}${bindir}/sparsetest bs=1 count=0 seek=1M
26}
27
28RDEPENDS_${PN}-gdb += "gdb"
29PACKAGES =+ "${PN}-gdb"
30FILES_${PN}-gdb = "${bindir}/gdb.sh"