Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # Handle U-Boot config for a machine |
| 2 | # |
| 3 | # The format to specify it, in the machine, is: |
| 4 | # |
| 5 | # UBOOT_CONFIG ??= <default> |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 6 | # UBOOT_CONFIG[foo] = "config,images,binary" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 7 | # |
| 8 | # or |
| 9 | # |
| 10 | # UBOOT_MACHINE = "config" |
| 11 | # |
| 12 | # Copyright 2013, 2014 (C) O.S. Systems Software LTDA. |
| 13 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 14 | UBOOT_BINARY ?= "u-boot.${UBOOT_SUFFIX}" |
| 15 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 16 | python () { |
| 17 | ubootmachine = d.getVar("UBOOT_MACHINE", True) |
| 18 | ubootconfigflags = d.getVarFlags('UBOOT_CONFIG') |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 19 | ubootbinary = d.getVar('UBOOT_BINARY', True) |
| 20 | ubootbinaries = d.getVar('UBOOT_BINARIES', True) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 21 | # The "doc" varflag is special, we don't want to see it here |
| 22 | ubootconfigflags.pop('doc', None) |
| 23 | |
| 24 | if not ubootmachine and not ubootconfigflags: |
| 25 | PN = d.getVar("PN", True) |
| 26 | FILE = os.path.basename(d.getVar("FILE", True)) |
| 27 | bb.debug(1, "To build %s, see %s for instructions on \ |
| 28 | setting up your machine config" % (PN, FILE)) |
| 29 | raise bb.parse.SkipPackage("Either UBOOT_MACHINE or UBOOT_CONFIG must be set in the %s machine configuration." % d.getVar("MACHINE", True)) |
| 30 | |
| 31 | if ubootmachine and ubootconfigflags: |
| 32 | raise bb.parse.SkipPackage("You cannot use UBOOT_MACHINE and UBOOT_CONFIG at the same time.") |
| 33 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 34 | if ubootconfigflags and ubootbinaries: |
| 35 | raise bb.parse.SkipPackage("You cannot use UBOOT_BINARIES as it is internal to uboot_config.bbclass.") |
| 36 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 37 | if not ubootconfigflags: |
| 38 | return |
| 39 | |
| 40 | ubootconfig = (d.getVar('UBOOT_CONFIG', True) or "").split() |
| 41 | if len(ubootconfig) > 0: |
| 42 | for config in ubootconfig: |
| 43 | for f, v in ubootconfigflags.items(): |
| 44 | if config == f: |
| 45 | items = v.split(',') |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 46 | if items[0] and len(items) > 3: |
| 47 | raise bb.parse.SkipPackage('Only config,images,binary can be specified!') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 48 | d.appendVar('UBOOT_MACHINE', ' ' + items[0]) |
| 49 | # IMAGE_FSTYPES appending |
| 50 | if len(items) > 1 and items[1]: |
| 51 | bb.debug(1, "Appending '%s' to IMAGE_FSTYPES." % items[1]) |
| 52 | d.appendVar('IMAGE_FSTYPES', ' ' + items[1]) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 53 | if len(items) > 2 and items[2]: |
| 54 | bb.debug(1, "Appending '%s' to UBOOT_BINARIES." % items[2]) |
| 55 | d.appendVar('UBOOT_BINARIES', ' ' + items[2]) |
| 56 | else: |
| 57 | bb.debug(1, "Appending '%s' to UBOOT_BINARIES." % ubootbinary) |
| 58 | d.appendVar('UBOOT_BINARIES', ' ' + ubootbinary) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 59 | break |
| 60 | elif len(ubootconfig) == 0: |
| 61 | raise bb.parse.SkipPackage('You must set a default in UBOOT_CONFIG.') |
| 62 | } |