Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Meta-perl packagegroup" |
| 2 | |
| 3 | inherit packagegroup |
| 4 | |
| 5 | PROVIDES = "${PACKAGES}" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 6 | PACKAGES = "\ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | packagegroup-meta-perl \ |
| 8 | packagegroup-meta-perl-extended \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 9 | ${@bb.utils.contains("DISTRO_FEATURES", "ptest", "packagegroup-meta-perl-ptest-packages", "", d)} \ |
| 10 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 12 | RDEPENDS:packagegroup-meta-perl = "\ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | adduser \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 14 | libalgorithm-diff-perl \ |
| 15 | libauthen-sasl-perl \ |
| 16 | libauthen-radius-perl \ |
| 17 | libcapture-tiny-perl \ |
| 18 | libcgi-perl \ |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 19 | libcompress-raw-bzip2-perl \ |
| 20 | libcompress-raw-lzma-perl \ |
| 21 | libcompress-raw-zlib-perl \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 22 | libdbd-sqlite-perl \ |
| 23 | libclass-method-modifiers-perl \ |
| 24 | libdigest-hmac-perl \ |
| 25 | libdigest-sha1-perl \ |
| 26 | libconfig-autoconf-perl \ |
| 27 | libcrypt-openssl-guess-perl \ |
| 28 | libcrypt-openssl-random-perl \ |
| 29 | libcrypt-openssl-rsa-perl \ |
| 30 | libhtml-parser-perl \ |
| 31 | libhtml-tree-perl \ |
| 32 | libhtml-tagset-perl \ |
| 33 | libimport-into-perl \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 34 | libio-compress-perl \ |
| 35 | libio-compress-lzma-perl \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 36 | libio-socket-ssl-perl \ |
| 37 | libio-stringy-perl \ |
| 38 | libipc-signal-perl \ |
| 39 | libcurses-perl \ |
| 40 | libmime-charset-perl \ |
| 41 | libmime-types-perl \ |
| 42 | libmodule-pluggable-perl \ |
| 43 | libmodule-runtime-perl \ |
| 44 | libmodule-build-tiny-perl \ |
| 45 | libdata-hexdump-perl \ |
| 46 | libnet-dns-perl \ |
| 47 | libnet-libidn-perl \ |
| 48 | libnet-dns-sec-perl \ |
| 49 | libnet-ldap-perl \ |
| 50 | libnet-ssleay-perl \ |
| 51 | libnet-telnet-perl \ |
| 52 | libproc-waitstat-perl \ |
| 53 | libdevel-globaldestruction-perl \ |
| 54 | libenv-perl \ |
| 55 | libfile-slurp-perl \ |
| 56 | libfile-slurper-perl \ |
| 57 | libtext-iconv-perl \ |
| 58 | libtext-diff-perl \ |
| 59 | libtext-charwidth-perl \ |
| 60 | libtext-wrapi18n-perl \ |
| 61 | libxml-libxml-perl \ |
| 62 | libxml-filter-buffertext-perl \ |
| 63 | libxml-sax-writer-perl \ |
| 64 | libextutils-config-perl \ |
| 65 | libextutils-cppguess-perl \ |
| 66 | libextutils-helpers-perl \ |
| 67 | libextutils-installpaths-perl \ |
| 68 | libextutils-parsexs-perl \ |
| 69 | liblocale-gettext-perl \ |
| 70 | libmoo-perl \ |
| 71 | librole-tiny-perl \ |
| 72 | libunix-statgrab \ |
| 73 | libstrictures-perl \ |
| 74 | libsub-exporter-progressive-perl \ |
| 75 | libsub-uplevel-perl \ |
| 76 | libterm-readkey-perl \ |
| 77 | libtest-deep-perl \ |
| 78 | libtest-harness-perl \ |
| 79 | libtest-nowarnings-perl \ |
| 80 | libtest-warn-perl \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 81 | libunicode-linebreak-perl \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 82 | po4a \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 83 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 84 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 85 | RDEPENDS:packagegroup-meta-perl-extended = "\ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 86 | logcheck \ |
| 87 | mime-construct \ |
| 88 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 89 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 90 | RDEPENDS:packagegroup-meta-perl-ptest-packages = "\ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 91 | libmime-types-perl-ptest \ |
| 92 | libio-socket-ssl-perl-ptest \ |
| 93 | libdata-hexdump-perl-ptest \ |
| 94 | libauthen-sasl-perl-ptest \ |
| 95 | libnet-dns-perl-ptest \ |
| 96 | libnet-dns-sec-perl-ptest \ |
| 97 | libnet-ssleay-perl-ptest \ |
| 98 | libtest-harness-perl-ptest \ |
| 99 | libdigest-sha1-perl-ptest \ |
| 100 | libdigest-hmac-perl-ptest \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 101 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 102 | |
| 103 | EXCLUDE_FROM_WORLD = "1" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 104 | |
| 105 | # perl-module-encode is preferred over libencode-perl |
| 106 | # libencode-locale-perl depends on libencode-perl |