blob: c20929510ab6a2c069c77ce29ee4f376309efea4 [file] [log] [blame]
Thang Q. Nguyen7d0f84a2021-09-23 06:47:52 +00001SUMMARY = "Phosphor OpenBMC Mt.Jade Platform Init Service"
2DESCRIPTION = "Phosphor OpenBMC Mt.Jade Platform Init Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
11DEPENDS += "systemd"
12RDEPENDS:${PN} += "libsystemd"
13RDEPENDS:${PN} += "bash"
14
15SRC_URI = " \
16 file://ampere_platform_init.sh \
Chau Ly0a0f3482023-04-13 05:06:28 +000017 file://ampere_uart_console_setup.sh \
18 file://ampere_uartmux_ctrl.sh \
Thang Q. Nguyen7d0f84a2021-09-23 06:47:52 +000019 file://ampere-platform-init.service \
20 "
21
22SYSTEMD_PACKAGES = "${PN}"
23SYSTEMD_SERVICE:${PN} = "ampere-platform-init.service"
24
25do_install () {
26 install -d ${D}${sbindir}
27 install -m 0755 ${WORKDIR}/ampere_platform_init.sh ${D}${sbindir}/
Chau Ly0a0f3482023-04-13 05:06:28 +000028 install -m 0755 ${WORKDIR}/ampere_uart_console_setup.sh ${D}${sbindir}/
29 install -m 0755 ${WORKDIR}/ampere_uartmux_ctrl.sh ${D}/${sbindir}/
Thang Q. Nguyen7d0f84a2021-09-23 06:47:52 +000030 install -d ${D}${systemd_unitdir}/system/
31 install -m 0644 ${WORKDIR}/ampere-platform-init.service ${D}${systemd_unitdir}/system
32}