blob: 301e65598992585e7ff990dd6a6fd861a4e173f3 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Lightweight crypto and SSL/TLS library"
2DESCRIPTION = "mbedtls is a lean open source crypto library \
3for providing SSL and TLS support in your programs. It offers \
4an intuitive API and documented header files, so you can actually \
5understand what the code does. It features: \
6 \
7 - Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, \
8 Camellia and XTEA \
9 - Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5 \
10 - Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG \
11 - Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, \
12 ECDSA and ECDH \
13 - SSL v3 and TLS 1.0, 1.1 and 1.2 \
14 - Abstraction layers for ciphers, hashes, public key operations, \
15 platform abstraction and threading \
16"
17
18HOMEPAGE = "https://tls.mbed.org/"
19
Patrick Williams73bd93f2024-02-20 08:07:48 -060020LICENSE = "Apache-2.0 | GPL-2.0-or-later"
21LIC_FILES_CHKSUM = "file://LICENSE;md5=379d5819937a6c2f1ef1630d341e026d"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000022
23SECTION = "libs"
24
25S = "${WORKDIR}/git"
Patrick Williams44b3caf2024-04-12 16:51:14 -050026SRCREV = "5a764e5555c64337ed17444410269ff21cb617b1"
27SRC_URI = "git://github.com/Mbed-TLS/mbedtls.git;protocol=https;branch=mbedtls-2.28 \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050028 file://run-ptest \
29 "
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000030
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050031inherit cmake update-alternatives ptest
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000032
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050033PACKAGECONFIG ??= "shared-libs programs ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000034PACKAGECONFIG[shared-libs] = "-DUSE_SHARED_MBEDTLS_LIBRARY=ON,-DUSE_SHARED_MBEDTLS_LIBRARY=OFF"
35PACKAGECONFIG[programs] = "-DENABLE_PROGRAMS=ON,-DENABLE_PROGRAMS=OFF"
36PACKAGECONFIG[werror] = "-DMBEDTLS_FATAL_WARNINGS=ON,-DMBEDTLS_FATAL_WARNINGS=OFF"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060037# Make X.509 and TLS calls use PSA
38# https://github.com/Mbed-TLS/mbedtls/blob/development/docs/use-psa-crypto.md
39PACKAGECONFIG[psa] = ""
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050040PACKAGECONFIG[tests] = "-DENABLE_TESTING=ON,-DENABLE_TESTING=OFF"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000041
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050042EXTRA_OECMAKE = "-DLIB_INSTALL_DIR:STRING=${libdir}"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000043
Andrew Geisslerc5535c92023-01-27 16:10:19 -060044# For now the only way to enable PSA is to explicitly pass a -D via CFLAGS
45CFLAGS:append = "${@bb.utils.contains('PACKAGECONFIG', 'psa', ' -DMBEDTLS_USE_PSA_CRYPTO', '', d)}"
46
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000047PROVIDES += "polarssl"
48RPROVIDES:${PN} = "polarssl"
49
50PACKAGES =+ "${PN}-programs"
51FILES:${PN}-programs = "${bindir}/"
52
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060053ALTERNATIVE:${PN}-programs = "hello"
54ALTERNATIVE_LINK_NAME[hello] = "${bindir}/hello"
55
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000056BBCLASSEXTEND = "native nativesdk"
Patrick Williams2194f502022-10-16 14:26:09 -050057
58CVE_PRODUCT = "mbed_tls"
59
Patrick Williams2a254922023-08-11 09:48:11 -050060CVE_STATUS[CVE-2021-43666] = "backported-patch: Fix merged upstream https://github.com/Mbed-TLS/mbedtls/pull/5310"
61CVE_STATUS[CVE-2021-45451] = "backported-patch: Fix merged upstream https://github.com/Mbed-TLS/mbedtls/commit/9a4a9c66a48edfe9ece03c7e4a53310adf73a86c"
Patrick Williamsb9af8752023-01-30 13:28:01 -060062
Andrew Geissler8f840682023-07-21 09:09:43 -050063# Strip host paths from autogenerated test files
64do_compile:append() {
65 sed -i 's+${S}/++g' ${B}/tests/*.c 2>/dev/null || :
66 sed -i 's+${B}/++g' ${B}/tests/*.c 2>/dev/null || :
67}
68
Patrick Williamsb9af8752023-01-30 13:28:01 -060069# Export source files/headers needed by Arm Trusted Firmware
70sysroot_stage_all:append() {
71 sysroot_stage_dir "${S}/library" "${SYSROOT_DESTDIR}/usr/share/mbedtls-source/library"
72 sysroot_stage_dir "${S}/include" "${SYSROOT_DESTDIR}/usr/share/mbedtls-source/include"
73}
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050074
75do_install_ptest () {
76 install -d ${D}${PTEST_PATH}/tests
77 cp -f ${B}/tests/test_suite_* ${D}${PTEST_PATH}/tests/
78 find ${D}${PTEST_PATH}/tests/ -type f -name "*.c" -delete
79 cp -fR ${S}/tests/data_files ${D}${PTEST_PATH}/tests/
80}