blob: 295da982ec8bfdb8f3fc647fe9db2eb2ba09b2ab [file] [log] [blame]
Patrick Williams39653562024-03-01 08:54:02 -06001inherit features_check
2REQUIRED_DISTRO_FEATURES = "ptest"
3
4require recipes-core/images/core-image-minimal.bb
5require conf/include/ptest-packagelists-meta-networking.inc
6
7SUMMARY = "meta-networking ptest test image"
8
9DESCRIPTION += "Also including the ${MCNAME} ptest package."
10HOMEPAGE = "https://www.openembedded.org/"
11
12PTESTS_META_NETWORKING = "${PTESTS_SLOW_META_NETWORKING} ${PTESTS_FAST_META_NETWORKING} ${PTESTS_PROBLEMS_META_NETWORKING}"
13
14IMAGE_INSTALL:append = " ${MCNAME}-ptest openssh"
15
16BBCLASSEXTEND = "${@' '.join(['mcextend:'+x for x in d.getVar('PTESTS_META_NETWORKING').split()])}"
17
18# The image can be sufficiently large (~1.8GB) that we need to be careful that it fits in a live
19# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
20# box) and explicitly add up to 1500MB.
21IMAGE_OVERHEAD_FACTOR = "1.0"
22IMAGE_ROOTFS_EXTRA_SPACE = "324288"
23# If a particular ptest needs more space, it can be customized:
24#IMAGE_ROOTFS_EXTRA_SPACE:virtclass-mcextend-<pn> = "1024288"
25
26# ptests need more memory than standard to avoid the OOM killer
27QB_MEM = "-m 1024"
28# If a particular ptest needs more memroy, it can be customized:
29#QB_MEM:virtclass-mcextend-<pn> = "-m 4096"
Patrick Williams44b3caf2024-04-12 16:51:14 -050030QB_MEM:virtclass-mcextend-nftables = "-m 2048"
Patrick Williams39653562024-03-01 08:54:02 -060031
32TEST_SUITES = "ping ssh parselogs ptest"
33
34# Sadly at the moment the full set of ptests is not robust enough and sporadically fails in random places
35PTEST_EXPECT_FAILURE = "1"
36
37python () {
38 if not d.getVar("MCNAME"):
39 raise bb.parse.SkipRecipe("No class extension set")
40}
41