blob: 084e3c4080628e76d3b5d4ab2756961977679a40 [file] [log] [blame]
Patrick Williams44b3caf2024-04-12 16:51:14 -05001DESCRIPTION = "libtorrent is a feature complete C++ bittorrent implementation \
2 focusing on efficiency and scalability."
3HOMEPAGE = "https://libtorrent.org/"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d8b6cb42d66e6b3c47a909c3ce678a7b"
6
7DEPENDS = "boost openssl"
8
9SRC_URI = "git://github.com/arvidn/libtorrent.git;branch=master;protocol=https \
10 git://github.com/arvidn/try_signal.git;branch=master;protocol=https;destsuffix=git/deps/try_signal;name=try_signal"
11
12SRCREV = "74bc93a37a5e31c78f0aa02037a68fb9ac5deb41"
13SRCREV_try_signal = "105cce59972f925a33aa6b1c3109e4cd3caf583d"
14SRCREV_FORMAT .= "_try_signal"
15
16S = "${WORKDIR}/git"
17
18inherit cmake pkgconfig python3targetconfig
19
20EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release"
21
22PACKAGECONFIG ??= "python3"
23PACKAGECONFIG[python3] = "-Dpython-bindings=ON,-Dpython-bindings=OFF,python3-distutils-extra-native"
24
25# Strip host paths from autogenerated files
26do_install:append() {
27 sed -i 's+${STAGING_LIBDIR}+${libdir}+g' ${D}${libdir}/pkgconfig/${BPN}.pc
28}
29
30PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3-${BPN}', '', d)}"
31FILES:python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/*"