blob: e45175f5a5a3f0e3179141c31301b0c40438018d [file] [log] [blame]
Patrick Williams44b3caf2024-04-12 16:51:14 -05001SUMMARY = "Parsing made fun ... using typing."
2HOMEPAGE = "https://github.com/hgrecco/flexparser"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=32f547dac365c355d2cdbcd7ebea9144"
5
6DEPENDS += "python3-setuptools-scm-native"
7SRC_URI[sha256sum] = "692e7524d9e14b2b1231b772b091d7d6296951deb383f5a67bfbd0ecb0b9fa9a"
8
9inherit pypi python_setuptools_build_meta ptest
10
11PYPI_PACKAGE = "flexparser"
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS:${PN}-ptest += " \
18 python3-pytest \
19 python3-unittest-automake-output \
20"
21
22do_install_ptest() {
23 install -d ${D}${PTEST_PATH}/testsuite
24 cp -rf ${S}/flexparser/testsuite/* ${D}${PTEST_PATH}/testsuite/
25}
26
27RDEPENDS:${PN} += " \
28 python3-compression \
29 python3-email \
30 python3-logging \
31"