blob: 3b0b47097c27dbe89bdb3d764063c92ccf179079 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "A suite of security-related network utilities based on \
2the SSH protocol including the ssh client and sshd server"
3DESCRIPTION = "Secure rlogin/rsh/rcp/telnet replacement (OpenSSH) \
4Ssh (Secure Shell) is a program for logging into a remote machine \
5and for executing commands on a remote machine."
6HOMEPAGE = "http://www.openssh.com/"
7SECTION = "console/network"
8LICENSE = "BSD-2-Clause & BSD-3-Clause & ISC & MIT"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=072979064e691d342002f43cd89c0394"
10
11DEPENDS = "zlib openssl virtual/crypt"
12DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
13
14SRC_URI = "http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
15 file://sshd_config \
16 file://ssh_config \
17 file://init \
18 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
19 file://sshd.service \
20 file://sshd.socket \
21 file://sshd@.service \
22 file://sshdgenkeys.service \
23 file://volatiles.99_sshd \
24 file://run-ptest \
25 file://fix-potential-signed-overflow-in-pointer-arithmatic.patch \
26 file://sshd_check_keys \
27 file://add-test-support-for-busybox.patch \
28 file://0001-regress-banner.sh-log-input-and-output-files-on-erro.patch \
29 file://0001-systemd-Add-optional-support-for-systemd-sd_notify.patch \
30 "
Patrick Williams44b3caf2024-04-12 16:51:14 -050031SRC_URI[sha256sum] = "490426f766d82a2763fcacd8d83ea3d70798750c7bd2aff2e57dc5660f773ffd"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060032
33CVE_STATUS[CVE-2007-2768] = "not-applicable-config: This CVE is specific to OpenSSH with the pam opie which we don't build/use here."
34
35# This CVE is specific to OpenSSH server, as used in Fedora and Red Hat Enterprise Linux 7
36# and when running in a Kerberos environment. As such it is not relevant to OpenEmbedded
37CVE_STATUS[CVE-2014-9278] = "not-applicable-platform: This CVE is specific to OpenSSH server, as used in Fedora and \
38Red Hat Enterprise Linux 7 and when running in a Kerberos environment"
39
40CVE_STATUS[CVE-2008-3844] = "not-applicable-platform: Only applies to some distributed RHEL binaries."
41
42PAM_SRC_URI = "file://sshd"
43
44inherit manpages useradd update-rc.d update-alternatives systemd
45
46USERADD_PACKAGES = "${PN}-sshd"
47USERADD_PARAM:${PN}-sshd = "--system --no-create-home --home-dir /var/run/sshd --shell /bin/false --user-group sshd"
48INITSCRIPT_PACKAGES = "${PN}-sshd"
49INITSCRIPT_NAME:${PN}-sshd = "sshd"
50INITSCRIPT_PARAMS:${PN}-sshd = "defaults 9"
51
52SYSTEMD_PACKAGES = "${PN}-sshd"
Patrick Williams705982a2024-01-12 09:51:57 -060053SYSTEMD_SERVICE:${PN}-sshd = "${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-socket-mode','sshd.socket', '', d)} ${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-service-mode','sshd.service', '', d)}"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060054
55inherit autotools-brokensep ptest pkgconfig
56DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
57
Patrick Williams705982a2024-01-12 09:51:57 -060058# systemd-sshd-socket-mode means installing sshd.socket
59# and systemd-sshd-service-mode corresponding to sshd.service
60PACKAGECONFIG ??= "systemd-sshd-socket-mode"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060061PACKAGECONFIG[kerberos] = "--with-kerberos5,--without-kerberos5,krb5"
62PACKAGECONFIG[ldns] = "--with-ldns,--without-ldns,ldns"
63PACKAGECONFIG[libedit] = "--with-libedit,--without-libedit,libedit"
64PACKAGECONFIG[manpages] = "--with-mantype=man,--with-mantype=cat"
Patrick Williams705982a2024-01-12 09:51:57 -060065PACKAGECONFIG[systemd-sshd-socket-mode] = ""
66PACKAGECONFIG[systemd-sshd-service-mode] = ""
Patrick Williamsac13d5f2023-11-24 18:59:46 -060067
68EXTRA_AUTORECONF += "--exclude=aclocal"
69
70# login path is hardcoded in sshd
71EXTRA_OECONF = "'LOGIN_PROGRAM=${base_bindir}/login' \
72 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} \
73 --without-zlib-version-check \
74 --with-privsep-path=${localstatedir}/run/sshd \
75 --sysconfdir=${sysconfdir}/ssh \
76 --with-xauth=${bindir}/xauth \
77 --disable-strip \
78 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemd', '--without-systemd', d)} \
79 "
80
81# musl doesn't implement wtmp/utmp and logwtmp
82EXTRA_OECONF:append:libc-musl = " --disable-wtmp --disable-lastlog"
83
Patrick Williams73bd93f2024-02-20 08:07:48 -060084# Work around ICE on mips/mips64 starting in 9.6p1
85EXTRA_OECONF:append:mips = " --without-hardening"
86EXTRA_OECONF:append:mips64 = " --without-hardening"
87
Patrick Williams03514f12024-04-05 07:04:11 -050088# Work around ICE on powerpc64le starting in 9.6p1
89EXTRA_OECONF:append:powerpc64le = " --without-hardening"
90
Patrick Williamsac13d5f2023-11-24 18:59:46 -060091# Since we do not depend on libbsd, we do not want configure to use it
92# just because it finds libutil.h. But, specifying --disable-libutil
93# causes compile errors, so...
94CACHED_CONFIGUREVARS += "ac_cv_header_bsd_libutil_h=no ac_cv_header_libutil_h=no"
95
96# passwd path is hardcoded in sshd
97CACHED_CONFIGUREVARS += "ac_cv_path_PATH_PASSWD_PROG=${bindir}/passwd"
98
99# We don't want to depend on libblockfile
100CACHED_CONFIGUREVARS += "ac_cv_header_maillock_h=no"
101
102do_configure:prepend () {
103 export LD="${CC}"
104 install -m 0644 ${WORKDIR}/sshd_config ${B}/
105 install -m 0644 ${WORKDIR}/ssh_config ${B}/
106}
107
108do_compile_ptest() {
109 oe_runmake regress-binaries regress-unit-binaries
110}
111
112do_install:append () {
113 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then
114 install -D -m 0644 ${WORKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd
115 sed -i -e 's:#UsePAM no:UsePAM yes:' ${D}${sysconfdir}/ssh/sshd_config
116 fi
117
118 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then
119 sed -i -e 's:#X11Forwarding no:X11Forwarding yes:' ${D}${sysconfdir}/ssh/sshd_config
120 fi
121
122 install -d ${D}${sysconfdir}/init.d
123 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/sshd
124 rm -f ${D}${bindir}/slogin ${D}${datadir}/Ssh.bin
125 rmdir ${D}${localstatedir}/run/sshd ${D}${localstatedir}/run ${D}${localstatedir}
126 install -d ${D}/${sysconfdir}/default/volatiles
127 install -m 644 ${WORKDIR}/volatiles.99_sshd ${D}/${sysconfdir}/default/volatiles/99_sshd
128 install -m 0755 ${S}/contrib/ssh-copy-id ${D}${bindir}
129
130 # Create config files for read-only rootfs
131 install -d ${D}${sysconfdir}/ssh
132 install -m 644 ${D}${sysconfdir}/ssh/sshd_config ${D}${sysconfdir}/ssh/sshd_config_readonly
133 sed -i '/HostKey/d' ${D}${sysconfdir}/ssh/sshd_config_readonly
134 echo "HostKey /var/run/ssh/ssh_host_rsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
135 echo "HostKey /var/run/ssh/ssh_host_ecdsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
136 echo "HostKey /var/run/ssh/ssh_host_ed25519_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
137
138 install -d ${D}${systemd_system_unitdir}
Patrick Williams705982a2024-01-12 09:51:57 -0600139 if ${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-socket-mode','true','false',d)}; then
140 install -c -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_system_unitdir}
141 install -c -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_system_unitdir}
142 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
143 -e 's,@SBINDIR@,${sbindir},g' \
144 -e 's,@BINDIR@,${bindir},g' \
145 -e 's,@LIBEXECDIR@,${libexecdir}/${BPN},g' \
146 ${D}${systemd_system_unitdir}/sshd.socket
147 fi
148 if ${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-service-mode','true','false',d)}; then
149 install -c -m 0644 ${WORKDIR}/sshd.service ${D}${systemd_system_unitdir}
150 fi
Patrick Williamsac13d5f2023-11-24 18:59:46 -0600151 install -c -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_system_unitdir}
152 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
153 -e 's,@SBINDIR@,${sbindir},g' \
154 -e 's,@BINDIR@,${bindir},g' \
155 -e 's,@LIBEXECDIR@,${libexecdir}/${BPN},g' \
Patrick Williams705982a2024-01-12 09:51:57 -0600156 ${D}${systemd_system_unitdir}/*.service
Patrick Williamsac13d5f2023-11-24 18:59:46 -0600157
158 sed -i -e 's,@LIBEXECDIR@,${libexecdir}/${BPN},g' \
159 ${D}${sysconfdir}/init.d/sshd
160
161 install -D -m 0755 ${WORKDIR}/sshd_check_keys ${D}${libexecdir}/${BPN}/sshd_check_keys
162}
163
164do_install_ptest () {
165 sed -i -e "s|^SFTPSERVER=.*|SFTPSERVER=${libexecdir}/sftp-server|" regress/test-exec.sh
166 cp -r regress ${D}${PTEST_PATH}
167 cp config.h ${D}${PTEST_PATH}
168}
169
170ALLOW_EMPTY:${PN} = "1"
171
172PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server"
173FILES:${PN}-scp = "${bindir}/scp.${BPN}"
174FILES:${PN}-ssh = "${bindir}/ssh.${BPN} ${sysconfdir}/ssh/ssh_config"
175FILES:${PN}-sshd = "${sbindir}/sshd ${sysconfdir}/init.d/sshd ${systemd_system_unitdir}"
176FILES:${PN}-sshd += "${sysconfdir}/ssh/moduli ${sysconfdir}/ssh/sshd_config ${sysconfdir}/ssh/sshd_config_readonly ${sysconfdir}/default/volatiles/99_sshd ${sysconfdir}/pam.d/sshd"
177FILES:${PN}-sshd += "${libexecdir}/${BPN}/sshd_check_keys"
178FILES:${PN}-sftp = "${bindir}/sftp"
179FILES:${PN}-sftp-server = "${libexecdir}/sftp-server"
180FILES:${PN}-misc = "${bindir}/ssh* ${libexecdir}/ssh*"
181FILES:${PN}-keygen = "${bindir}/ssh-keygen"
182
183RDEPENDS:${PN} += "${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-keygen ${PN}-sftp-server"
184RDEPENDS:${PN}-sshd += "${PN}-keygen ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-keyinit pam-plugin-loginuid', '', d)}"
185# gdb would make attach-ptrace test pass rather than skip but not worth the build dependencies
186RDEPENDS:${PN}-ptest += "${PN}-sftp ${PN}-misc ${PN}-sftp-server make sed coreutils openssl-bin"
187
188RPROVIDES:${PN}-ssh = "ssh"
189RPROVIDES:${PN}-sshd = "sshd"
190
191RCONFLICTS:${PN} = "dropbear"
192RCONFLICTS:${PN}-sshd = "dropbear"
193
194CONFFILES:${PN}-sshd = "${sysconfdir}/ssh/sshd_config"
195CONFFILES:${PN}-ssh = "${sysconfdir}/ssh/ssh_config"
196
197ALTERNATIVE_PRIORITY = "90"
198ALTERNATIVE:${PN}-scp = "scp"
199ALTERNATIVE:${PN}-ssh = "ssh"
200
201BBCLASSEXTEND += "nativesdk"